0

I tried to add a guest account to my laptop and when I restarted the computer, the only login option I have is the Guest Account. Choosing this account restarts the computer into the Safari-only configuration. There is no Systems Preferences available in this mode.

I did not unchoose my administrator account. How did this happen? And how do I get it back?

  • 2
    Let's see whether we can narrow this down a bit: Which OS X version are you using? Do you FireVault enabled? What happens if you log in as Guest and then log out again, are the other logins displayed then? While logged in as Guest, can you use Fast User Switching to log in as another user? – nohillside Jul 6 '13 at 6:49
1

I think safe mode would work better. Here are the instructions, from the Apple Support website

To start up into Safe Mode (to Safe Boot), do this:

  1. Be sure your Mac is shut down.
  2. Press the power button.
  3. Immediately after you hear the startup tone, hold the Shift key. The Shift key should be held as soon as possible after the startup tone, but not before the tone.
  4. Release the Shift key when you see the gray Apple icon and the progress indicator (looks like a spinning gear).

Once your in, go to System Preferences and disable Find My Mac (iCloud settings) and Guest User (Users and Groups). Reboot. You should be able to login normally. If you would still like a guest user, just go back and enable Find My Mac.

-2

Try restarting the computer by clicking at the Apple logo () in the upper left screen corner and choosing Restart.

You must log in to answer this question.

protected by Community Mar 7 '15 at 13:58

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged .