I am using my iPhone 4S to sync with Google Calendar. I don't want it to show the items of the "Sports"-calendar though, because it's a full list of possible group activities at my local gym and it would clog up my calendar.

After unselecting "Sports" in the list of calendars, the iPhone still keeps showing entries of the "Sports" calendar.

Rebooting the iPhone does not help either. Going to calendars and settings still shows the Sports-calendar unselected. When I press on "Spinning (18:45-19:30)" it would automatically add the Sports-calendar back to the list of calendars to sync.

What can I do to not see the calendar items from the Sports-calendar?

1 2

  • The whether sucks in Den Haag :), I would say when deselecting will apply only to new items, the old one will be still there. Delete them. Then try to add new item in Google and see if it shows up.
    – Ruskes
    Jul 3, 2013 at 16:44
  • 1
    I assume you did go here to deselect the calenders you do not want synced. Google website: www.google.com/calendar/iphoneselect
    – Ruskes
    Jul 3, 2013 at 16:54
  • Thanks Buscar, your suggestion worked. If you answer it, I'll select your answer as the best answer.
    – ujjain
    Jul 3, 2013 at 18:28
  • You are welcome :) ....the weather still sucks in Den Haag, here in California its about 30 Celsius. PS; I used to live in Baarn (next to Hilversum).
    – Ruskes
    Jul 3, 2013 at 19:57
  • Yes! It's the Netherlands. Summer started June 21, but we still have gray cold days and are still waiting for better weather.
    – ujjain
    Jul 3, 2013 at 20:39

2 Answers 2


You should go here to deselect the calenders you do not want synced.

Google website: http://www.google.com/calendar/iphoneselect

it looks like this

google sync

  • I had a similar issue with adding group calendars (i.e., calendars for Google Groups to which I had edit privileges) as well as subscribed (read-only) calendars. Checking those calendars on [this tiny "Sync Select" settings page on Google fixed the issue for me. Why Google has this obscure, separate settings page for sync instead of consolidated these preferences into the regular Calendar settings page is beyond me: google.com/calendar/syncselect
    – Crowder
    Feb 14, 2015 at 16:55

This is odd. I'd presume that your Sports calendar events somehow got to one of your other calendars without you knowing. What I'd do is:

  1. first tap on "Hide all" when in Calendars

  2. Next ensure that you do not see Any of your "Sports" calendar events (any events at all from other calendars shouldn't be visible either)

  3. Next start selecting to show the rest of your calendars one by one without ever selecting the "Sports" calendar

  4. The first time you see the culprit events appear - this is the malignant calendar which contains events from "Sports"

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .