I have a MacBook Air 2013 that does not have MacOS installed, but is booting Windows 8 Pro 64-bit (clean install, not upgraded from Windows 7) in a vhdx file via EFI. I'm not having any problems in booting Windows 8 or using it.

However, I can't seem to get the Boot Camp drivers to install properly. I don't need Boot Camp to help me boot, I just need the drivers to get things like the keyboard, trackpad, and wifi adapter functioning properly.

I downloaded Boot Camp Support Software 5.0.5033 and extracted the contents. I was not able to run Boot Camp setup directly. I got the message "Installation Error. Boot Camp x64 is unsupported on this computer model". From my research, this often happens when trying to install Boot Camp in Windows. As described here, I opened an elevated command prompt and navigated to the BootCamp\Drivers\Apple folder and ran "msiexec /i BootCamp.msi". This launched the Boot Camp install process, which appeared to install the Boot Camp drivers with no problems. I saw no error messages. After the install finished, I rebooted. The install seems to have partly worked - for example, the LED keyboard was dark before and now it is lit up, and a taskbar notification icon was added that says "ENG" and indicates I'm using an Apple keyboard.

However, I've noticed a number of things that suggests the drivers didn't install properly.

The Boot Camp Control Panel has only one tab, "Startup Disk". Based on this link which describes a typical Boot Camp install in Windows, I would expect the Control Panel to have tabs such as Keyboard, Trackpad, etc. None of those are present.

The Device Manager still shows the default drivers for devices such as the keyboard. Again, I would expect the Device Manager to look as it does in the previous link. Instead, I don't see any of the drivers that Boot Camp said it was installing. Also, the "Other Devices" branch has several devices such as the Network Controller, Bluetooth USB Host Controller, and PCI Simple Communications Controller listed as not functioning properly.

Finally, things like two-finger-clicking the trackpad to open the Windows context menu, or Fn+F5/Fn+F6 to decrease/increase the keyboard brightness, are not working.

I've tried running the Boot Camp install again, and it found the previous install and offered to repair it. I did this, and rebooted, but nothing has changed.

I've tried going into the BootCamp\Drivers\Apple folder and running the individual driver install executables. Again, these run with no problem and indicate that they succeeded by displaying green checkmarks, but again nothing changes.

I've tried going into Device Manager and updating the drivers manually (for instance, I told it to look in the Windows\System32\DriverStore\FileRepository folders for the various Apple drivers such as the trackpad or wifi), but Windows just says it can't find any compatible drivers there.

I would try using the Apple Software Update, except I can't get the wifi adapter working. If that's likely to fix the problem, then I'll go get a dongle to hook up my Cat 5 cable.

In summary, is there anything special I need to know when installing the Boot Camp drivers in Windows 8?

Thank you!

Edit 9/22:

It may be that the drivers in the Boot Camp Support Software 5.0.5033 are not recent enough for the hardware in the 2013 Mac Air. I'm not a driver expert but here are my observations.

I started by trying to get the wifi adapter driver updated. According to a teardown*, the Air has a Broadcom BCM4360. According to wikidevi* the Windows hardware ID for that is PCI\VEN_14E4&DEV_43A0.

I then went to \BootCamp\Drivers\Broadcom and opened BroadcomEthernet64.exe using 7Zip. There is only one .inf file in there, b57nd60a.inf. I opened that. I found references to Windows Vista, Windows 7, and Server 2008, but no Windows 8. I found many IDs named PCI\VEN_14e4&DEV_xxxx, but no PCI\VEN_14E4&DEV_43A0.

I also opened BroadcomNetworkAdapter64.exe. There is only one .inf file in there, bcmwl6.inf. I opened that and found references to Windows 7, but no Windows 8. I found IDs named PCI\VEN_14E4&DEV_43xx, which are a little closer to the mark, but no PCI\VEN_14E4&DEV_43A0.

My guess is that when I try to install the Boot Camp drivers, the process completes without any errors but many of the drivers are not actually installed because the Windows hardware IDs in the .inf files do not match the hardware in the machine.

I looked around to see if anyone else had a Windows 8 driver for the Broadcom BCM4360. The only one I've found so far is from ASUS*. I downloaded that driver package, scanned it for malware, opened it (it's a .zip file), and found one .inf file, bcmwl63.inf. I opened that and sure enough I found references to Windows 8 and PCI\VEN_14E4&DEV_43A0 in it. I then successfully installed the ASUS driver on the Air, and Windows Device Manager now recognizes that it has a wifi adapter. However, I'm not able to see any wireless networks, although there are plenty around me. I tried rebooting and that didn't help. My guess is that the ASUS driver has some particulars related to ASUS hardware that prevent it from working properly on the Air.

So is this perhaps just a question of waiting until Apple updates their Boot Camp drivers for Windows 8 to include the more modern hardware in the Air 2013?

  • I can't post any more links. I'll try to add these links in a comment, but they're not crucial.
  • Links: Teardown. Windows hardware ID. ASUS driver.
    – FSharpN00b
    Sep 23, 2013 at 2:58
  • I've started a thread here to ask if there are going to be updated Boot Camp drivers soon to include the hardware in the Mac Air 2013. It seems Linux users had a similar issue, namely that the BCM4360 is new enough that there aren't many drivers available for it yet. I searched Broadcom's site for one, without success.
    – FSharpN00b
    Sep 23, 2013 at 23:55
  • After a whole day of Googling I found this thread: forums.macrumors.com/showthread.php?t=1659481 The link to ASUS page worked for me to install the WLAN driver properly. But I haven't tried yet the other drivers.
    – alu
    Dec 27, 2013 at 16:36

1 Answer 1


I know this is 3 months late. But if anyone is still searching, the answer is to use the Boot Camp Assistant to download the drivers. The ones from the Apple Bootcamp website will not work.

If you check out this article: http://support.apple.com/kb/HT5634

Click on the MacBook Air link at the center of the page and you will see:

MacBook Air (13-inch, Mid 2013) and MacBook Air (11-inch, Mid 2013)

need to have drivers downloaded from BootCamp Assistant. So, you will need to boot into your Mac partition and plug in a USB drive and download the drivers.

PS: If the drivers fail to download, make sure your USB stick is attached to the left USB port (the screen facing you). I remember reading it somewhere on Apple's support forum - but cannot find the link at the moment to cite it.

I did this and it worked for me. The Boot Camp drivers installed and I did not get the x64 error message as well.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .