0

I have changed the language from my MacOS system and now it won't save the screenshots anymore. Is there a way to fix it?

Thanks.

8
  • We need bit more information!
    – Ruskes
    Jul 2 '13 at 5:22
  • Did you change your keyboard layout ? What system ect...
    – Ruskes
    Jul 2 '13 at 5:22
  • 3
    Are you taking screenshots using keyboard shortcuts?
    – Ruskes
    Jul 2 '13 at 5:24
  • Yes, cmd+shift+ctrl+[3-4], they won't save on desktop. I changed the language while I had Snow Leopard, and they stopped working, now I have Mountain Lion and the problem continues…
    – Werner
    Jul 2 '13 at 17:05
  • Please tell what language did you choose? What I am thinking is you keyboard layout is now different.
    – Ruskes
    Jul 2 '13 at 17:49
1

Changing the Language could lead to screen shot not finding the right location to save to.

So I would recommend to change the output, = save location for the keyboard short cut.

There are few ways to do this one of them is in Terminal.

For example, if I want to have the screenshots appear in my Pictures folder, I would use:

defaults write com.apple.screencapture location ~/Pictures/

To have the changes take effect, you then must type:

killall SystemUIServer

You can change the saved screenshot location back to the default setting by specifying the desktop again:

defaults write com.apple.screencapture location ~/Desktop/

Again, you’d need to kill SystemUIServer for changes to take effect.

4
  • I can't even upvote your comments and your answer… sometimes it's really annoying to have this low points account. Thanks for complementing with a deeper answer.
    – Werner
    Jul 2 '13 at 18:27
  • Don't worry about up voting, you will gather points fast the way you are proceeding :), there u go just got 10 up for your answer .)
    – Ruskes
    Jul 2 '13 at 18:29
  • I usually don't get too many points because I normally find the answer for my questions before I ask them over here. Two more and I can up vote haha xD. But I'll stop with the off-topic… if there were a message system it would be better…
    – Werner
    Jul 2 '13 at 18:38
  • You can always ask a question and then answer it your self :) If it is a good answer you might get points :)
    – Ruskes
    Jul 2 '13 at 18:48
1

I fixed this issue updating the output folder with the following commands on the terminal:

defaults write com.apple.screencapture location ~/Desktop
killall SystemUIServer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .