5

In Chrome, when I download a file with an extension that the OS doesn't recognize (in this case, .erb, the dialog defaults to appending .txt to the end of it. I highlight the .txt and delete it before hitting save, but then I open the directory and find foo.erb.txt where I should find foo.erb.

How do I get the system to save the file with the extension I told it to?

0

Apparently this is a chrome bug that's been around for some time and never seems to have been fixed.

Several bug reports are available but I haven't ever seen a fix or even a chrome extension that fixes it. I think if the web server identifies the content or mime type correctly it might work, but looks like there's nothing you can do about that from the browser-side of things.

http://code.google.com/p/chromium/issues/detail?id=38213 http://code.google.com/p/chromium/issues/detail?id=39708&q=download%20filename%20extensions&colspec=ID%20Pri%20M%20Iteration%20ReleaseBlock%20Cr%20Status%20Owner%20Summary%20OS%20Modified

0

Came across this issue today and after searching on Google realized that this is a generic issue with Chrome which remained not fixed since long. However, there is a workaround to manually add the extension while downloading. In Chrome, go to settings -> Advanced -> Downloads -> Enable "Ask Where to Save each file before downloading".

After enabling this, a small dialog box appears where in you can specify the name/download location. You can add the extension in that window.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .