0

On my OS X 10.8.2 (12C54) I use more desktops (4). I've mapped the keyboard shortcuts cmd+{1,2,3,4} to switch to dekstop {1,2,3,4}. However the second and third are mixed up. If I use cmd+2 it switches to desktop 3 and cmd+3 switches to desktop 2.

I double checked the keyboard shortcuts and they are mapped correctly.

So I thought whatever, I will just mix my setting as well, still it will be a fix for me. Interestingly enough the issue sometime go away, however then my "wrong" settings are really wrong.

Anyone have a solution, experiencing the same thing?

1

Is Mission Control set to automatically rearrange your spaces based on most recent use? That might trigger the behaviour you see in certain circumstances. Check System Preferences -> Mission Control and that the highlighted checkbox is unchecked.

enter image description here

  • Its a good advice, let me go with this a 'bit before I mark it answered, just to confirm. Still I don't get why it mixes only 2/3. I use 1 and 4 just as much. – p1100i Jul 1 '13 at 11:54
  • @burninggramma Absolutely, it might not be the answer at all, but I wanted to add the image of the setting which I could not do in a comment. – Lizzan Jul 1 '13 at 11:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .