0

on my Lion Server I have noticed that the permissions for certain folders seem to be screwed up.

When I look at the Get Info for the folder I see strange things in the permissions section. There are many users with grey symbols with a question mark next to them. It says unknown next to them. When I unlock the permissions I try to delete them, but pressing the - button has no effect.

The problem is on the second hard drive, which I use for data. I also tried to repair the permissions from the recovery partition but it will only let me repair the permissions on the system hard drive.

How can I reset the permissions to a standard value? Or can I repair permissions on the secondary hard drive as well?

Thanks

1
  • How is the second hard drive formatted? – mmmmmm Jul 1 '13 at 12:46
1

First, as an FYI, you only need to boot into the recovery partition to repair permissions when you are trying to repair permissions on your computer's boot drive. To do it for any other drive, simple select it in Disk Utility and click the Repair Disk Permissions button. This may solve your problem, so try that first.

After that, the simplest solution is to turn on "Ignore Ownership" on the drive. Navigate to the drive in Finder and use Get Info... to see the permissions, as you have been doing. Underneath the permissions, you'll see a box that says "Ignore Ownership on this volume." Check that box. This will ignore all permissions on the volume and allow any user or program to do anything on the drive. Follow this link for more information on the benefits and perils of doing this: https://larryjordan.com/articles/mac-os-set-hard-drive-permissions/

Alternatively:

You can reset the permissions using the Terminal App. Open the app in Applications > Utilities > Terminal.

Navigate to the folder you're having trouble with using the "cd" command, then use the command

sudo chmod -R 644 .

This will change the directory and every file within that directory to the default OS X permissions. For more information on how to use Terminal and chmod, take a look at this tutorial:

http://computers.tutsplus.com/tutorials/navigating-the-terminal-a-gentle-introduction--mac-3855

0

On a folder or file, right click -> Information -> Share and permissions

Or from Terminal : chmod, chown, ...

3
  • that is where I see the users "Unknown"... – Joseph Jul 1 '13 at 9:25
  • So try with sudo chown -R myUserName:myGroup myFolder – avignat Jul 1 '13 at 9:46
  • The files are owned by another user. The problem is that second and third users do not "stick" but are called "unknown". – Joseph Jul 2 '13 at 5:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .