1

How can I remote desktop to a Windows 8 machine using an email address login?

If enter my username as myusername@gmail.com and leave the domain blank I will be taken to the Windows 8 login screen and receive the login error:

Other User

The username or password is incorrect. Try again.

When I press OK, the Windows 8 login screen will just show my username as myusername, and if I add @gmail.com I can login.

The next time I open a remote desktop connection the client has split my user name up into:

User name: myusername

Domain: gmail.com

This also doesn't allow me to directly login and I get the same authentication error.

How can I preserve my username as myusername@gmail.com and login directly?

I am using Microsoft Remote Desktop Connection Client for Mac 2.1.0 on OS X 10.8.4.

2
+50

Try adding .\ in front of your email address. I'm not familiar with Windows 8, but with previous versions this directs Windows to perform authentication on the local system, rather than on the domain in which it resides.

If this doesn't work, try also hostname\, where hostname is the name of the computer you are trying to log into.

2

Use microsoftaccount as your domain, e.g.:

microsoftaccount\your@email.address

Save your connection settings to an .rdp file, then edit it with a text editor and add the following line:

enablecredsspsupport:i:0

Source1 Source2

If at this point the RDP connection complains about the lack of Network Level Authentication, you need to turn it off on the host machine (source):

Network Level Auth

0

Prefixing the email address with .\ will allow you to logon to the local system without a domain requirement:

.\username@gmail.com

This is how I would use the email address username@gmail.com to logon.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .