7

I received the following error when trying to join Freenode with Adium:

*** Notice -- You need to identify via SASL to use this server

I understand why they want me to use SASL in my case, and I can see this is a common problem. I can see that Adium supports SASL, and I can find the help ticket that prompted the Adium dev group to add SASL support.

What I can't find is... how to use SASL in Adium. I don't see any options for enabling SASL or configuring it or anything. Thanks for your help.

  • Is there an option for something like a NickServ password? – Gaelan Jun 28 '13 at 20:55
  • There are two username/password options: one for the IRC server and one for the proxy. I have entered a pw for the IRC server, but I haven't registered yet. I have to connect, first. – TravisThomas Jun 28 '13 at 21:00
  • Oh. You'll need to register to use SASL, I think. – Gaelan Jun 28 '13 at 21:02
  • OK, I've registered but I'm getting the same error. – TravisThomas Jun 28 '13 at 21:13
9

Adium 1.5 doesn't support using SASL for IRC. That will be added in 1.6: https://trac.adium.im/ticket/14478.

In 1.6, there will be a checkbox to activate SASL. When that is activated, the password field is treated as the SASL password.

The following build can be used successfully: Adium_1.6hgr5915.dmg

And this guide may help if you have question using it after you've enabled SASL.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .