9

In short, I have an audio file that is too large for iTunes Match (This item is not eligible for iCloud), but I'd still like to listen to it on my phone. In days past I was still able to drag the track to my iPhone in the sidebar, but that feature now seems to be disabled.

Metadata for audio track too large for iTunes MatchThis item is not eligible for iCloud error message

5
  • 2
    What version of iTunes and is the device set to sync over USB, WiFi or not at all to that iTunes library?
    – bmike
    Jun 27 '13 at 14:36
  • Latest version of iTunes, device is set to sync over WiFi.
    – nipponese
    Jun 27 '13 at 14:52
  • 2
    Latest for what OS? It really helps the site if you put in these details. It's just a suggestion and you don't need to - but we aim to have questions usable even 2 years down the road when iTunes 14 is out (or whatever)
    – bmike
    Jun 27 '13 at 14:53
  • Sorry, but I thought screenshot implied this was for OS X. 10.8.4 specifically, but that doesn't seem relavant to the problem.
    – nipponese
    Jun 27 '13 at 15:51
  • 2
    It it were me, I'd use Audacity or some other audio editor to break the monolithic track up into sub tracks and create a custom album. On the song options, I'd probably select part of a gapless album.
    – ephsmith
    Jun 27 '13 at 16:02
9

I made the file kind "audiobook," and then they seemed to sync fine, as audiobooks. Since they were lecture files, that's just fine with me.

1
  • I was actually trying to upload an audiobook to the iphone and marking files as audiobook totally helped :)
    – Dannie P
    Jul 19 '17 at 3:25
4

Just spoke to Sr. Apple Support staff. There is no official way to do this without turning off iTunes Match, selecting the content you want moved to either the iPhone or the iPad (in iTunes), syncing and then turning iTunes Match back on. While not a great solution, that is the official word.

2
  • I've also heard of people storing these files in dropbox or another file storage program that allows playing of the file. It's not the same as being integrated within the Music app, but the file does get on your iPhone for listening.
    – bmike
    Sep 10 '13 at 21:30
  • 1
    This is frustrating, but I guess at least it's possible. Apple is being stupid here. Let us store whatever you allow in iCloud, then sync the rest of the ineligible stuff in iTunes as normal. I guess I'll give this a try. 90GB of music is getting to be ridiculous.
    – user2702
    Feb 9 '15 at 22:54
4

I changed the file type to 'Audiobook', (Right click on the file in iTunes, Get Info, Options, then change 'media kind' to audiobook') and then it allowed me to drag and drop the file on to my iPhone in iTunes. Then, in the Music app on the iPhone, tap 'More' in the bottom right corner, and 'audiobooks' will appear in the list.

Took about an hour of faffing about with iTunes Match before I discovered this tip. Then it was done in about 20 seconds.

2

As a possible workaround you could use a different app than the default Music.app for this particular song. Some apps (Azul, for example) permit you to use simple iTunes sharing to put media inside and they are independent of the iTunes library.

It is not ideal but it does solve the problem.

0

I have found to date the best fix to this dilemma is to change the "Media Kind" to iTunes U. Select the track or tracks and then select options, you will see the option to change the media type. This option will be available to only songs that have Not been added from your mac or pc to iCloud i.e. there's the cloud with a line through it next to the track. I have the latest iTunes 11.1.1 and iOS 7 on my iPhone. I used this method to add 323 teaching files that won't sync to the cloud, not sure why because I have other teaching files that are the same length and they sync to the cloud just fine. Turning iTunes match off then moving the files to my phone, then turning iTunes Match back on didn't work, it just erased the files i just moved over when turning match back on.

0

I had the same issue. My solution was to go onto my iPhone 5S, turn OFF iTunes Match in settings. At the same time, I also turned on Automatic Downloads Music. One of these solved my problem. When I plugged my phone back into the computer, all of my music synced. Good luck.

0

I had great success with going into iTunes and selecting Get InfoOptions and changing the type from Music to Audiobook and selecting the checkboxes for Do Not Shuffle and Remember Location.

Then you can selective-sync audiobooks with your iPhone and sync like in the old days.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .