When I am using Apple Mail, it insists on downloading the full body and attachment 100.000+ email I have on gmail, which eats up my hard drive, and makes the interactive search function annoyingly slow.

Is there any way to make Mail only create indexes for Subject/From fields, and keep all the actual mail content remotely?

Possibly, it could cache "new" mail locally (from the last week or so), but to cache the full body of every single mail from years ago is just insane with the amount of mail one has these days.

  • Did you set it up in both GMail and Mail as IMAP?
    – maksimov
    Commented Jun 27, 2013 at 15:49
  • It seems that the option to not download all mails was removed in Apple Mail since Mavericks. The answers below offer workarounds. Another solution, if you are not particularly attached to the Apple Mail interface, would be to just use a different mail client. Thunderbird for example does have options on what is actually downloaded to your machine for offline use : everything / nothing / only some folders / only recent mails with a setting of how many days.
    – mivk
    Commented Aug 16, 2019 at 11:12

3 Answers 3


Apple's mail on 10.11 and older will download all the mail that the server tells it about. The macOS 10.12 mail has a setting to optimize mail storage that might store header information for all mails, but not download the body and attachments of older emails.

You can opt in to that from the Apple menu - about this Mac - storage - manage, but it seems to only be offered when you have significant storage burden from Mail and/or specific mail server configurations.

Since that's how the mail client was designed and codes, you will need to go to gmail's web interface and hide some of the folders from IMAP access to prevent the client, macOS mail.app, from ever seeing the messages. Exchange has a setting to determine a time range of mail to sync, but google and IMAP do not appear to have that feature.

Gmail -> Settings -> Labels

Most people I know that use mail like you describe (keep all of it all the time) choose to not show All Mail in IMAP and then just clean their inbox when the volume becomes unwieldy.

  • 1
    +1 because I've been battling this with mail forever and never thought of this. Thanks @bmike!!
    – ckpepper02
    Commented Jun 27, 2013 at 14:57

Maybe this is a new setting but GMail has a setting under IMAP that you can limit the number of messages per folder - starting at 1000.

GMail >> Settings >> IMAP Settings >> Folder Size Limits


One possibility is setting Gmail to POP mail in Mountain Lion - a well-hidden but perfectly viable choice.

The trick is to hold down the Option key on the Create button, when adding an account, which turns the button into "Continue" and you can go on configuring it as a POP account.

In addition, I have my GMail accounts configured on the web as both IMAP, for the phone and iPad, and POP on the desktop ... working fine, for a long time.

  • I see a downvote, but no explanation of why?
    – Allan Bowe
    Commented Jul 21, 2013 at 21:49
  • 1
    Does POP limit downloads by protocol or is there some setting that is configurable to prevent downloading all 100k messages?
    – bmike
    Commented Dec 11, 2013 at 14:35
  • Open Mail preferences and look at the Advanced pane of your account. Where it says, "Remove Copy From Server" it doesn't mean to your computer, it means delete from server, period. Erased. So it's a "convenience" you don't have to use.
    – Zo219
    Commented Dec 18, 2013 at 20:23
  • If you use POP, you'll lose synchronisation - terrible idea if you use more than one device. If you're a GMail user, see: apple.stackexchange.com/a/136181/27384
    – jpillora
    Commented Jun 26, 2014 at 1:28
  • True, but I handle all my mail but for one icloud address on my MBPro ... the iPad gets the icloud mail, and this all works out for me. Of course, I have numerous email addresses.
    – Zo219
    Commented Jun 26, 2014 at 2:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .