I'm using vmWare Fusion 5.0.3 on Mac OS X, and the guest OS is also Mac OS X.

The problem: I can't set the guest OS display resolution to a reasonable value. "Reasonable" here means anything that will fit on my MacBook Air's 1440x900 screen. Right now it's using 1680x1050. I can get (a) a window that fits the 1680x1050 guest display but which is bigger than my physical display, or (b) a window that fits my display but scales down the 1680x1050 to a painfully small size so that it all fits. If I go to full screen I also get 1680x1050 scaled to fit the screen.

I tried resizing the window, but that just changes the window size and scaling-- I still get 1680x1050 on the guest OS.

I'm not too picky as to size, but I want something that actually fits on my screen.

For what it's worth, I do have vmWare tools installed. I reinstalled them just to make sure, it didn't help.

2 Answers 2


I fixed this by, basically, screwing around with /Library/Preferences/com.apple.windowserver.plist on the guest copy of Mac OS X and getting lucky. First I tried removing that file and rebooting, but that didn't help. Next, I noticed that the 1680x1050 resolution was stored in that file, so I decided to edit it and change the numbers to 1440x900 (I figured if it's going to force a fixed resolution, I'll at least make it match the physical display) and rebooted.

The result is that the normal resize behavior is back. Changing the vmWare window size now updates the guest OS's screen resolution, as would normally be the case.

I don't know why this worked, but things are back to normal now.


Your solution didn't work for me, at least when using the Mac OS X Mavericks.

What worked actually was holding ⌥ Opt while clicking on the Scaled option, as described in a post on VMware forums.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .