I am running Windows 8 and OS X Lion using Bootcamp, and ran into an issue where OS X is no longer bootable (empty gray progress bar on startup). Googling this error led me to believe it could be any number of things, but regardless it seems the best (least painful) way to solve it is to reinstall OS X.

I am able to run the Windows 8 partition with no problem, and thought I could backup my important files from OS X to an external hard drive and then use the Recovery partition to reinstall OS X.

The issue is that, when I attempt to copy files from the Mac partition (no issue with the Windows partition), the copy/paste dialog 'discovers' all the files and then silently fails without copying. I have seen a few possibilities for this error, however in following their steps (take ownership of target directory, drag and drop instead of copy/paste), nothing seems to work.

I don't want to clone the partition in case if there is something bad that I would be copying along with the clone, leaving me in the same state I'm currently in. If it is the case that the HDD is failing, I would still like to have the backup of the information I need.


I did manage to recover a fair amount of the files I needed through Windows, and if anybody else has this issue it is very helpful. I never even considered this option among the many others, but somehow it managed to pull the majority of my files off and onto an external drive.

I loaded Windows PowerShell in Administrator mode and ran the following script (it was a script to only copy directories that have files, but without modification it worked successfully):

$path = 'C:\source\directory'
$destination = 'e:\destination\directory’

Get-ChildItem $path -Directory |
    Foreach-Object  {if (($_.enumeratefiles() | measure).count -gt 0)
        Copy-Item -path $_.fullname -Destination $destination -Recurse}
  • Thanks for reporting back and sharing what you've learned about the issue in the meantime.
    – nohillside
    Aug 9 '13 at 6:31
  • 1
    No problem...its a somewhat singular issue I think, but at least I managed to recover the majority of my files. Some of them were damaged beyond repair and irrecoverable, however I was able to get the majority of the important ones.
    – the_e
    Aug 9 '13 at 14:22

If you are uncomfortable with that, you can also try some Windows solutions. I assume you already have Boot Camp Software installed in Windows, which would allow you to see your mac files (read only), but if not, or not in a while, download and install them here: Apple Boot Camp Software(latest version as of July 1, 2013)

You can also try a piece of 3rd party software called MacDrive 9 Standard. It has a lot of features for accessing and even possibly repairing Mac partitions from within Windows. MacDrive 9

  • I will look into MacDrive. I do have BootCamp up and running. What I was trying to do was copy the Mac files from the Windows partition onto an external hard drive, but that copy was continually failing.
    – the_e
    Jul 1 '13 at 20:38

I’ve had to recover files (usually from dying disks) multiple times, and from what I’ve tried and learned, this is (currently), my preferred method.

  1. Get an external harddrive, that can hold the maximum size of the one you want to recover from.
  2. Get RIP Linux, and boot your computer with it.
  3. Clone the harddrive to a file (on the external drive), by running ddrescue --direct --max-retries=10 ${inputDevice} ${outputFile} logFile.log. By doing this, you’ll have a file that you can access faster and try different recovery tools on. Keeping the log file also means you can interrupt the cloning and continue it later. The real command will actually depend, so if you’re not confortable with the command-line, say something so we can point you the right way to do it.
  4. Get PhotoRec to recover your files.

You could try a filesystem check from Single-User Mode

Start up the Mac while holding option, and then select your Macintosh HD, and before pressing the return key, press and hold the Command key and the S key. while holding them, press return, and once the screen goes black and text appears, let of of the Command and S keys.

When it finishes loading, you'll get a section of text as follows:

Singleuser boot -- fsck not done
Root device is read-only
If you want to make modifications to files:
    /sbin/fsck -fy
    /sbin/mount -uw /
if you wish to boot the system:
:/ root#

Some other messages may pop up after that, but once you see that on your screen, type that first sbin command:

/sbin/fsck -fy

That'll go though, check your filesystem for errors, and try to repair them, and if it does, then it will recheck, and rerepair if needed, up to three times.

Keep running that till it doesn't bring up "repairing" messages, or you get the EXACT same repairing messages twice in a row.

At that point, type reboot and see if it starts up. This is similar to using Recovery HD's disk utility to repair disk, but definitely has a higher success rate.

If at any point you get a:

Read: I/O error

then it means either the Hard Drive, Hard drive Cable or SATA controller is failing.

Though, if you are running Windows without a problem in boot camp from the same hard drive, it's not too likely that the Drive or SATA controller is failing.

Also, if you get up to your user account screen, when you type in your password, hold the shift key and then press the return key, and let go of the shift key when you see your desktop, so that you start up with the minimum startup applications and processes.

If you get it booting, I recommend copying all your files off to another disk, reformatting your Macintosh HD volume and Reinstalling OS X, since the FSCK single user method mostly just gets your drive to a workable state but doesn't usually prevent it from degrading in the future.


Use a Live-CD of Ubuntu (or others) to access your hard drive and backup up all you data.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .