7

I prefer a fast tracking speed for mouse on my MacBook.

  enter image description here

However, this setting is only good for the logged in user. When I logged out, the mouse is slow again.

How can I change the mouse tracking speed in the login window (i.e. when all users are logged out)?

  • Have you tried the suggested answer here? superuser.com/questions/179288/… – Elliott Apr 3 '18 at 9:45
  • @Elliott Don't think this works anymore, at least not without disabling SIP. – nohillside Jul 9 '18 at 14:10
  • Anyway, what need do you have for the mouse on the login screen? To select one of the accounts it's enough to type the first few letters of the (displayed) user name. – nohillside Jul 9 '18 at 14:13
  • @nohillside it's the need of tuning my machine to work in a way that I prefer... – ohho Jul 12 '18 at 2:06
1

If you are saying that you would like to set the mouse tracking speed for all users of the system I do not believe there is a way to do that. Each will have his/her own preference.

If you are saying that when you set your preference and then log out/log in under the same user and unexpectedly find that your preferences are not retained then there should be a fix.

Likely cause ,either:

The the permissions on the preference file are set incorrectly -- This might be fixed in disk utility -- repair permissions. Logout and then login.

or

The permission file is corrupt. You should move it to the desktop, logout, login and set the permissions. Should stick now. I believe the preference is stored here: ~/Library/Preferences/com.apple.driver.AppleHIDMouse.plist

  • 1
    The setting is stored in ~/Library/Preferences/.GlobalPreferences.plist, not com.apple.driver.AppleHIDMouse.plist. – Lri Jun 22 '13 at 6:27
  • 3
    I'd like to change the mouse speed in the login window (i.e., when all users are logged out). – ohho Oct 10 '13 at 10:58
  • 4
    This doesn't answer the OP's question. Even if all users' mouse speeds are set faster than default, it's still slow on the login screen. Very annoying :/ – efr4k Apr 20 '16 at 21:37
0

Run in terminal:

defaults -currentHost write NSGlobalDomain com.apple.trackpad.scaling -float #.#
defaults write NSGlobalDomain com.apple.trackpad.scaling -float #.#`

1.0 is about the middle of the GUI.

Check current value set by the slider in the GUI with:

defaults read | grep trackpad.scaling

This is for the trackpad, adapt as necessary if using a mouse

-1

I haven't tried it, but maybe setting the mouse tracking speed for the root user will do the trick. You need to enable the root account first: https://support.apple.com/hr-hr/HT204012

Then log in as root, open the system preferences and modify the tracking options.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .