I am unable to get full screen brightness on my 13" MacBook Pro when booted to Windows 8 Professional. As a result, I can't use my machine outside unless I'm booted to OS X. I checked all the power settings in Windows and everything's already set to 100%. Is there a workaround for this?


It appears that there is an Adaptive Brightness feature in Windows 8 that messes with the overall brightness of the MBP

If you just installed Windows 8 on your laptop and the screen won’t stay at the brightness level you want, it’s probably because the adaptive brightness feature isn’t working right on your system. Here’s how to disable it.

  1. Open up the Windows desktop with Win + D, click the power management icon in the tray, and then choose More power options from the menu.
  2. Once here, click the Change plan settings link on the selected plan.
  3. Then click the Change advanced power settings link.
  4. And now, browse down to Display > Enable adaptive brightness, and change the settings there to Off.

Naturally, it would be best to have the feature actually work, so you could make sure to update your drivers. If you still want to disable, here’s how to do it.

Just so we’re clear, here’s how to change the brightness on your Windows 8 laptop… hit the Win+I shortcut key combination (that’s a capital i), and then you’ll see the brightness control right there.

Disable Windows 8 Adaptive Brightness

  • This is also an identical issue and process in Windows 10 – Andrew White Aug 14 '15 at 8:09

Tried Both methods at the same time and it has seemed to resolve the issue, However when i was in the change advanced power settings I changed the DIM Display section to 100% and just made sure all the display section options were at their highest possible brightness.

Issues resolved Cheers lads.


i have got the same problem which leads me to this post but the above solution doesn't work for me. Not a proper solution but i found a way around the problem. Set What to do when the lid closes option to Do Nothing for both 'On battery' and 'Plugged in' in power option. When you turn on your computer, close the lid and open it again and you will find keyboard shortcuts for screen brightness function after doing that. You can try this if the adaptive brightness setting does't do a thing for you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .