1

I'm trying to brew weechat, which has p11-kit as a dependency.

$ brew install p11-kit
==> Downloading http://p11-glue.freedesktop.org/releases/p11-kit-0.18.1.tar.gz
Already downloaded: /Library/Caches/Homebrew/p11-kit-0.18.1.tar.gz
==> Patching
patching file configure.ac
patching file configure
Hunk #1 succeeded at 17201 with fuzz 1.
patching file common/library.c
==> ./configure --prefix=/usr/local/Cellar/p11-kit/0.18.1 --without-trust-paths
==> make
     You might want to install the Automake and Perl packages.
     Grab them from any GNU archive site.
Can't locate Autom4te/C4che.pm in @INC (@INC contains: /usr/share/autoconf /Library/Perl/5.12/darwin-thread-multi-2level /Library/Perl/5.12 /Network/Library/Perl/5.12/darwin-thread-multi-2level /Network/Library/Perl/5.12 /Library/Perl/Updates/5.12.4 /System/Library/Perl/5.12/darwin-thread-multi-2level /System/Library/Perl/5.12 /System/Library/Perl/Extras/5.12/darwin-thread-multi-2level /System/Library/Perl/Extras/5.12 .) at /usr/bin/autom4te line 39.
BEGIN failed--compilation aborted at /usr/bin/autom4te line 39.
make: *** [configure] Error 1

I tried force linking autoconf

$ which autom4te
/usr/bin/autom4te
$ brew link --force autoconf
Linking /usr/local/Cellar/autoconf/2.69... 18 symlinks created
$ which autom4te
/usr/local/bin/autom4te

No dice. I keep getting the error from /usr/bin/autom4te Am I missing something?

Thank you for your help!

EDIT: I've opened an issue here https://github.com/mxcl/homebrew/issues/20586

1 Answer 1

1

I went ahead and renamed the files autoconf, autoheader, autom4te, autoreconf, autoscan, autoupdate and ifnames in /usr/bin to force my machine to use the ones made available in /usr/local/bin after a brew link --force autoconf.

Brewing worked without an issue.

I don't know where the files in /usr/bin/ came from or if I borked things up bad by doing this. I'm keeping the renamed files in place, just in case I ever remember what I did today when things start to stink.

(see https://github.com/mxcl/homebrew/issues/20586 for more troubleshooting)

2
  • These files are from Apples's Xcode and removing them is not a good idea.
    – mmmmmm
    Jan 29, 2014 at 16:14
  • I ran brew link --overwrite autoconf. Worked for me perfectly on macOS Catalina.
    – gillytech
    Feb 18, 2022 at 1:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .