1

I was forced to restart MacBook Pro when a kernel panic happened about 2 hours ago... Since then my computer would just stuck on the grey screen with the Apple logo every time I tried to reboot it. Some useful log appeared when I tried to boot it in Safe Mode and single user mode:

disk0s2: I/O error.

   0 [Level 3] [ReadUID 0] [Facility com.apple.system.fs] [ErrType IO] [ErrNo 5] [IOType Read] [PBlkNum 24] [LBlkNum 2][FSLogMsgID 327376684] [FSLogMsgOrder First]

   0 [Level 3] [ReadUID 0] [Facility com.apple.system.fs] [DevNode root_device] [MountPt /] [FSLogMsgID 327376684] [FSLogMsgOrder Last]

0 [Level 3] [ReadUID 0] [Facility com.apple.system.fs] [ErrType IO] [ErrNo 5] [IOType Read] [PBlkNum 55232] [LBlkNum 763][FSLogMsgID 375551380] [FSLogMsgOrder First]

0 [Level 3] [ReadUID 0] [Facility com.apple.system.fs] [DevNode root_device] [MountPt /] [FSLogMsgID 375551380] [FSLogMsgOrder Last]

0 [Level 3] [ReadUID 0] [Facility com.apple.system.fs] [ErrType IO] [ErrNo 5] [IOType Read] [PBlkNum 55008] [LBlkNum 749][FSLogMsgID 299898203] [FSLogMsgOrder First]

0 [Level 3] [ReadUID 0] [Facility com.apple.system.fs] [DevNode root_device] [MountPt /] [FSLogMsgID 299898203] [FSLogMsgOrder Last]

That was when the booting process got stuck. The log seemed to suggest that there were problems with the disk i/o and mounting the file system.

To you experts: Can you interpret what this means? Was this a hardware problem? Can you decide more specifically what the problem was? Do you have any suggestions of a potential fix?

Thanks, Stephen

0

Chrisii has the right idea.. test the drive, as the error log shows "disk0s2: I/O error" which suggests a failing drive.

If the test finds no errors, then you may have a corrupted install. Reinstall from the recovery disc, and your data should be fine.

Cheers,

Dave

  • Or, if you own Disk Warrior, this is the time to use it! – Zo219 Jun 17 '13 at 4:18
  • Yep, it's a hard drive failure. – StephenChen Jul 25 '13 at 5:59
0

Try to boot into recovery by holding down Cmd+R.

If your computer shipped with a Mac OS X Install disc, insert the installation disc, and restart the computer while holding the C key.

If using a Recovery partition or Internet Recovery (OS X Lion and later): When your computer finishes starting up, choose Disk Utility from the Utilities window.

If using an installation disc: Choose Disk Utility from the Installer menu. Important: If you started from an installation disc, do not click Continue in the first screen of the Installer. If you do, you must start from the disc again to access Disk Utility.

Click the First Aid tab.

Click the disclosure triangle to the left of the hard drive icon to display the names of your hard disk volumes and partitions.

Select your OS X volume.

Click Repair. Disk Utility checks and repairs the disk.

Hopefully this might solve the issue. Otherwise I suggest backing-up your data and reinstall OSX.

  • The recovery mode got stuck at the Apple logo with grey background... I've been waiting for more than 10 minutes, should I wait longer? How does the process normally take? – StephenChen Jun 17 '13 at 0:08
  • pending on the damage it can take long time, so go watch a movie or something. – Ruskes Jun 17 '13 at 0:19
  • Do you think that a hardware test can help? – StephenChen Jun 17 '13 at 1:23
  • Also... My computer restarted itself several times when I initiated the recovery mode. Is this normal? – StephenChen Jun 17 '13 at 1:29

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .