0

Have iPhone 4 with iOS 5.1.1
Trying to update to 6.1.2 (not the latest) via downloaded IPSW but unfortunately getting error:

iphone could not be restored device isn't eligible for the requested build

After searching for fix all over the internet found some suggestion like putting # in hosts file in line gs.apple.com but not helped.

Have you any idea why I'm getting this error and can't restore iphone?

1

Apple signs only the latest version of iOS. Previous iOS versions cannot be installed on iOS devices, even if you do so via an upgrade (and not downgrade). The iOS device will simply not allow you to upgrade to anything but the latest and greatest iOS version.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .