1

I have been working on a website on a test server test.domain.com for a few weeks now. I was always able to access the .htaccess password protected site using my iPad mini as well as my iPhone or using the Simulator.

.htaccess used:

AuthType Basic
    AuthName "Test Server"
    AuthUserFile /usr/local/www/test.domain.com/.htpasswd
Require valid-user

Somehow today I could not access the site anymore from my iPad mini. The site kept on loading, but no response was given to the GET request at all. No pop-up asking for the password either.

This was so weird. I tried reloading many times. Then I tried to access the site using Chrome on the same iPad where I was asked to enter the .htaccess username and password and it did work. For some off reason I had to enter the details twice, but anyways.

I decided to ask my partner to turn of the .htaccess password protection et voila! Access was granted again.

How come that I was not asked for entering the details again in Safari on the iPad? Where can I check how these details were stored if they had been?

0
1

Consider clearing Safari's cache of cookies and site specific data. This should clear Safari's record of login information used for your test web site.

Clear Cookies and Data

  1. Tap Settings;
  2. Tap Safari;
  3. Tap Clear Cookies and Data.

Apple publish further steps for clearing other Safari information in iOS: Safari web settings.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .