162

Switching between applications is easy with command-tab.

Switching between tabs is easy with command-} or control-tab.

Switching between separate windows within an application is easy with command-`.

However, that last one doesn't seem to work with Google Chrome (Version 27.0.1453.110) on OS X 10.8.4. Is there a leopard shortcut specific for Chrome to switch between different windows?

2

21 Answers 21

169

⌘ Cmd+` works for me with the same versions of Chrome and OS X, so it might be something specific to your installation.

You could try temporarily resetting Chrome's preferences or disabling extensions. Or change the shortcut from System Preferences or test if it works on a different account.

6
  • 23
    You're right... it does work. The problem is with OSX spaces. If I have two chrome windows open in the same space, CMD + ` switches between those windows. However, if I move chrome, or any other application, to two or more spaces, CMD + ` does not switch between those windows. I'm going to mark this as the answer since it does answer my question. I'll create a new question regarding switching between windows in different spaces. Jun 13, 2013 at 21:34
  • 3
    You guys save life time for me!!! it's awesome
    – dan zen
    Sep 28, 2014 at 1:48
  • 13
    @KrisAnderson, did you manage to ask that question somewhere? I'm struggling with the same problem. Dec 2, 2014 at 20:23
  • 4
    @KrisAnderson, would you mind sharing the new question you mentionned regarding switching between windows in different spaces. May 15, 2015 at 15:35
  • 2
    @KrisAnderson is it this question - apple.stackexchange.com/questions/50445/…. Unfortunately it doesn’t have an answer Aug 9, 2021 at 12:42
59

This issue is so annoying for me, and today I finally got it resolved! So, in hope to help some poor soul like myself, I want to share what I did:

Screenshot

  • Go to System Preference --> Keyboard --> Shortcuts tab --> Move focus to next window
  • Set it to + `

Updated screenshots for MacOS Ventura 13.3.1:

enter image description here

enter image description here

4
  • Thanks for this! Using a non english layout, it made it easy to figure out what it was Feb 20, 2020 at 20:42
  • In my case, this was already checked, but pressing this keystroke simply does nothing. I disabled and re-enabled the option, and edited the key to set it to the same thing (still <kbd>⌘</kbd> + <kbd>`</kbd>), then it suddenly starts working.
    – SOFe
    Aug 23, 2021 at 2:42
  • Saved my life - got kb with German layout (vielen dank) - key above Tab contains §/± chars. The backtick is between left shift and Y but cmd + ` didn't switch the window by default.
    – DraganS
    Aug 31, 2021 at 15:26
  • This only works if the window isn't maximized.
    – Max Ghenis
    Dec 18, 2021 at 0:56
13

To show Chrome windows (this applies to other apps as well) press: Control- (arrow down).

Active windows of the current application would be shown larger (if you've multiple monitors, they will show on other screen as well), including minimized at the bottom.

From there, use arrow keys to switch between different windows and confirm your selection with Enter or Space (to switch between all apps press Tab). It should work for multiple displays as well. Hit Escape to cancel the selection.

Above tested on El Capitan (10.11).

5
  • 1
    Doesn't show all windows if they're spread across different workspaces, which is what the gist of the problem is. Oct 6, 2016 at 16:36
  • @DanDascalescu It works for me with multiple monitors though.
    – kenorb
    Oct 6, 2016 at 17:50
  • 1
    Right, but do you have multiple spaces? Oct 6, 2016 at 21:06
  • Maybe if you hit your arrows towards another workspace, it'll switch to another? Or use the shortcuts, like Control-1 or 2, or Alt+Arrows?
    – kenorb
    Oct 7, 2016 at 9:07
  • 2
    This is the best answer for me, I need to be able to quickly identify and switch to Gmail vs. Hangouts vs. Calendar.
    – ukayer
    Sep 6, 2019 at 19:11
7

For those using Snow Leopard 10.6.8, these options can be set under the OSX "System Preferences" > Keyboard > "Keyboard Shortcuts" Tab > "Keyboard and Text Input".

Apparently, by default Cmd+` is set to "Move focus to next window in appl...". However, this shortcut doesn't work for me because my keyboard is Japanese, and therefore I need to press Shift to access the `. It turns out that OSX always receives a Shift+Cmd+@. So, what I did was to replace that shortcut with Cmd+@ and now it works.

Hope that helps people having similar issues.

PS: You can use the "Move focus to active or next window", which defaults to Ctrl+F4, Shift+Ctrl+F4 for the previous window.

0
5

@Hugo Chrome allows to set up more users to get more "environments" inside your chrome (bookmarks, opened tabs, session and so forth). it's very useful to split your business and private browsing.

So, ⌘ Cmd-Shift-M is very useful. :)

4
  • 2
    Welcome to Ask Different! This does not provide an answer to the question—leave a comment once you have sufficient reputation.
    – grg
    May 24, 2014 at 11:19
  • 4
    This doesn't address the question asked in any way... Would have been a down-vote if I had the reputation on this SE site for it.
    – josiah
    May 1, 2015 at 14:21
  • 1
    @Jehu, Hmm, there seems to be no way to switch between these "environments" when they have more than one windows.
    – Pacerier
    Jul 15, 2015 at 15:03
  • At least for me on a SE keyboard layout the Command + ` shortcut for witching between windows in chrome profiles does not work - so this would be the ONLY way to switch between chrome profiles via the keybaord Jan 20, 2022 at 9:33
4

My case was slightly different - one chrome window was normal ( not maximized ) and another chrome windows was maximized. The above solution cmd + ' didn't work in my case.

When one chrome window is maximized it gets its own space, found that i can use control key + left or right arrow keys to switch back between these 2 chrome windows.

Hope it helps.

0
2

Interestingly, the ⌘ Cmd-` shortcut doesn't work for me (Chrome 38.0 on Mac OS X 10.9.50).

But ⌘ Cmd-F1 seems to work instead (and works for other apps too).

Though, again, it doesn't work if the windows are spread across desktops/spaces.

1
  • 5
    CMD+F1 does nothing. Tested in Google Chrome 48 in El Capitan.
    – kenorb
    Mar 7, 2016 at 6:44
2

Control + F4 will switch back & forth between open chrome browsers but only after configuring the Function keys to only work with Fn key in System Preferences > keyboard options.

1
  • This cycles between all windows. So it would work if you only had two chrome windows open. Dec 11, 2015 at 23:24
2

So I found what was , for me , the real problem. I went into System Preferences" > Keyboard > "Keyboard Shortcuts" Tab > "Keyboard and Text Input and I found this:

Sorry for Italian lang.

Sorry for Italian lang.

Start from bottom, third row. Have attention for cmd + ' at first it was cmd + `

So I simply changed it and now It works perfectly.

Hope this can help.

1
  • It helped me to active the last radio button option (All Controls). Because I am not always in a Text Field. Oct 21, 2016 at 8:58
2

You can toggle between windows in the same Space/desktop, and also across all of them.

To toggle between windows of the same application in the same space use Cmd ⌘ + ` ("Move focus to the next window").

However, what shows windows in all spaces from the same app is the "Application Windows" shortcut: Ctrl ⌃ + which shows all of them:

enter image description here

Now you can either use keyboard arrows or click the one you want to transition to.

Pro tip

What's very helpful to me is using configuring a hot corner so I don't even need to press keys.

(Preferences -> Desktop & Screensaver -> Hot Corners): enter image description here

1

To switch between users in Chrome, use ⌘ Cmd-Shift-M and then use your arrow keys to select the user you want and hit Enter.

This isn't as fast as a key combination normally is but it is quicker than using the mouse. To see where this key combination comes from see Chrome's support forum.

2
  • 1
    Chrome users? What is that? The command doesnt do anything for me
    – Hugo
    Nov 27, 2013 at 13:14
  • "Chrome users" are currently seen in the "People" menu in Chrome on MacOS and also via clicking your user icon in the upper right hand corner. You can have multiple google accounts associated with Chrome (very handy). The keyboard shortcut in this answer allows to switch between people, even when minimized, which is exactly what I wanted to know. Thanks.
    – AdamE
    May 16, 2019 at 22:46
1

There will be ShortCuts “Alt+PageUp” & “Alt+PageDown” available in the next version of our extension TabIt - NewTab (precisely in v15.01). They will allow to switch between neighbouring Chrome windows.

2
  • Welcome to Ask Different! Please note that we have some rules you have to follow when linking to your own website.
    – Glorfindel
    Jan 13, 2019 at 19:20
  • On a second thought, these ShortCuts aren't appropriate for such an extension. But I have moved them to another one, called ChRAM: chrome.google.com/webstore/detail/chram/…
    – Alex
    Feb 15, 2019 at 15:07
1

In order for any suggested keyboard shortcuts to work, none of the windows can be in Full Screen. To exit Full Screen, choose View > Exit Full Screen.

1

If you have Chrome Windows maximized (ie. each Chrome window is in its own Spaces), the keyboard shortcut to toggle between Spaces will do the job for you. By default keyboard shortcut to toggle between Spaces is control + right arrow key or control + left arrow key. If this doesn't work, check for keyboard shortcuts on your mac under System Preferences > Keyboard > Mission Control and attributes 'Move left a space' and 'Move right a space'.

1

[MAC users] When you have several google sessions open or other applications as vscode with different projects per window, you can switch between them using COMMAND + TAB after that UP or DOWN to choose.

0

I had the same problem and when I went in to system preferences and keyboard shortcuts the shortcut was set to cmd+. When I marked it and gave it the same shortcut, It suddenly works just fine:)

0

I just do control+left/right arrow. Not sure if this only works because I have the swipe between apps enabled with my apple mouse...
UPDATE
I found that the problem was apparently in chrome itself(for me) and that to make it work you need the chrome windows to be minimized for it to work. The problem might be in the shortcut itself, but "cmd+`" does work with other applications. So, the solution I'm currently using is just to minimize and then manually increasing the window size to fit the full screen.
Found this answer from https://superuser.com/a/1177594. If this isn't the problem, try the other solutions.

2
  • That's the space switching shortcut, you need to place your windows in different adjacent spaces.
    – grg
    Jan 10, 2021 at 23:38
  • I changed it...
    – NerdOfDoom
    Jan 20, 2021 at 23:46
0

Review the mission control shortcuts for switching between OSX spaces. The following link answers your question because you are using Chrome browser AND OSX spaces. Also some sources frequently refer to spaces as desktops.

macOS: Navigating between desktops using keyboard shortcuts

1
  • The link you have provided opens up a question with three answers. Which of them are you referring to? Note that you can provide a direct link to an answer using the share button at the bottom of an answer. In addition, it is better practice to describe in your answer how the linked material answers the question explicitly with enough detail so that someone reading your answer later on can figure it out even if the linked material is deleted for some reason.
    – Alper
    Oct 16, 2022 at 19:03
0

Happy news for German/Austrian/Swiss keyboard users:

You cannot toggle with

cmd + `

You need to do

cmd + shift + `

1
  • This does not provide an answer to the question. Once you have sufficient reputation you will be able to comment on any post. Also, this has been available for the keyboard layouts you state for some time already. I think users could just refer to this answer. - From Review
    – Thinkr
    Oct 19, 2023 at 16:47
-2

cmd + works only if the windows are not in fullscreen mode. If they are in fullscreen mode, cmd + doesn't work.

-3

I'm using Mavericks and CMD+` does not work for me. However, CMD+. does.

1
  • 3
    CMD+. does nothing. Tested in Google Chrome 48 in El Capitan.
    – kenorb
    Mar 7, 2016 at 6:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .