0

I am trying to install xcode on my mac version : Mac OS X Lion 10.7.5 But I'm having a problem,

i download xcode version 4.6.2 from Appstore after i installed the app i clicked on the icon in the launchpad and it just opened and ask me to install device support so i click install and it ask for my password so i entered the pass and it wrote:

An unknown error occurred. See the install log for more details.

so i looked for this problem and i found that i can go to xcode icon, click on the option and click on "Show Package Contents" and than on Contents->Resources->Packages than i click "MobileDevice.pkg", again i entered my password and nothing happend like really nothing, the password is right and i dont know why it is like that

thank you for your help ilan.

  • What error? something like this? com.apple.SecurityServer: Failed to authorize right 'system.install.app-store-software' by client '/System/Library/PrivateFrameworks/PackageKit.framework/Versions/A/Resources/installd' [1063] for authorization created by '/System/Library/CoreServices/Installer.app' [1348] – Ruskes Jun 10 '13 at 1:46
  • Did you verify that you are logged in as Administrator in System Preferences > Users and Groups, it should say Admin under your name. – Ruskes Jun 10 '13 at 1:50
  • yes i'm under admin user – Ilan Finkel Jun 10 '13 at 6:26
  • about the error, where i can find the error? in the install log? – Ilan Finkel Jun 10 '13 at 6:27
  • Yes you can find it in there or in the Console. – Ruskes Jun 10 '13 at 14:48
1

I came across this issue in another post but not certain if the errors you are getting are the same but here it is. Source is provided below:

Use Pacifist to install MobileDevice.pkg!!! Simply open the file with pacifist click the top right Lock button that says Not Authorized Type your password and hit install once thats done install itunes normally or with pacifist worked great for me

SOURCE: http://www.tonymacx86.com/general-help/98821-xcode-itunes-mobiledevice-pkg-fix.html

0

I had a similar problem and I followed the answer to the question here: https://discussions.apple.com/thread/3863980?start=0&tstart=0

That fixed it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .