I'm setting up an NFS server (Ubuntu) to serve files to several Macs (10.7).

The way it's set up, I can log in from any Linux client and read/write over NFS exactly as expected. (I've set up ACL permissions on the server to cover multiple anonymous users and it works perfectly.)

I'm having trouble getting write permission from the Mac side, however. I've mounted the Mac Client about a million different ways, but still no dice.

I'm using the noowners option to mount, even, but that doesn't help either. (It shows the expected ownership and file permissions, and this is where I start banging my head.)

Check this out:

JAF-Mac:Arlington facemyer$ pwd
JAF-Mac:Arlington facemyer$ users 
JAF-Mac:Arlington facemyer$ groups
staff com.apple.sharepoint.group.1 com.apple.sharepoint.group.2 everyone _appstore localaccounts _appserverusr admin _appserveradm _lpadmin _lpoperator _developer com.apple.access_screensharing vianneynas
JAF-Mac:Arlington facemyer$ touch x
touch: x: Permission denied
JAF-Mac:Arlington facemyer$ ls -la
total 25444
drwxrwsr-x   9 facemyer  staff      4096 Jun  6 10:40 .
drwxrwsr-x  47 facemyer  staff      4096 Jun  6 10:44 ..
drwxrwsr-x   7 facemyer  staff      4096 Jun  6 10:40 2011
drwxrwsr-x   4 facemyer  staff      4096 Jun  6 10:40 2012
drwxrwsr-x   4 facemyer  staff      4096 Jun  6 10:40 2013

The really bizarre thing is that if I su to another user I created for testing this, it works as expected for that user. (I can view and edit the files as expected.)

Please tell me I'm not going insane, and that there's a reasonable explanation here...

  • Hmm...tried on another Mac that I haven't yet messed with - exact same issue. Maybe I am insane, but the evidence leads me to believe otherwise.
    – jfacemyer
    Commented Jun 7, 2013 at 15:04
  • Have you had any progress on this? I'm running into the same issue, it seems, but ONLY when saving files from Flash CS6??
    – L422Y
    Commented Jan 21, 2014 at 17:20
  • Sorry, nothing. I just eventually went with the Apple File System layer.
    – jfacemyer
    Commented Jan 23, 2014 at 2:35

1 Answer 1


Your noowners mention solved all of my issues. I would make sure all of your options are being applied w/ nfsstat -m -- mount_nfs likes to remove / add options and not list them when you just type mount I also am using launchctl configuration that runs a mount_nfs command, since automount was being unpredictable. I do see an s (setuid/setgid) up there in the permissions... I'm using nosuid...

Here's my working mount_nfs line, you probably can remove some of the options (some are duplicates), but I feel better having all the variations for some reason ;)

 mount_nfs -o "vers=3,noowners,nolocks,nolockd,nolock,nonlm,automounted,nosuid,hard,bg,noresvport,intr,rw,tcp,nfc"       <server>:/exports/myexport /Volumes/myexport

From ls -l from /Volumes:

drwxrwrwx  13 larry  staff   4.0K Jan 17 17:37 myexport

All folders within myexport are drwxrwrwx as well.

It's been an ongoing battle to get NFS and OSX working together but when it works it works flawlessly and fast. AFP is on the way out, and Apple is sticking with Samba, which has always been a pain in my neck, whether the clients are OSX or Windows, there was always some sort of issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .