I've tried to update my macbook pro to osx 10.8.4. While my macbook rebooted, it said, that the update failed. After this failed update, my Mac will no longer connect to my TL-WR841N router.

I clicked the OK button and waited until it completely started. Then I tried to connect to my wlan (with no success). I got a "Connection timeout.". So I disabled/re-enabled my wlan, removed the wlan interface in the network panel, rebooted my macbook, added the network panel and got rid of the connection timeout. But it wasn't working: I got the error, that I couldn't connect to this network. I tried a lot: Repaired the access privileges in the utility program, changed my location in the network panel. I also reseted my router, but this was not the problem, because I could connect to it with my iphone without problems.

Then I discovered that I can connect to every network that has no encryption or has WEP encryption. I changed my wlan security settings in my router to "NO" and "WEP" (just for testing) and I could connect. But when I change it to WPA or WPA2 I can not connect (Yes, the password is right)..

What can I do now? How can I solve that? OSX 10.8.4 log says that it improves some points concerning wlan, so I think it has something to do with that. However beside the wlan my macbook is working great and (in contrast to the error message when updating), the "About Mac" panel says OSX 10.8.4.

  • It's a long shot, but if you add your router model - someone might be able to confirm that they have similar issues or have a working set. I'll think if I can offer any suggestions other than clearing all network settings from the Mac and starting the setup again… Also, I would perhaps upload a picture of /System/Library/CoreServices/Network Diagnostics showing the part of your network stack the tool says is failing.
    – bmike
    Jun 6, 2013 at 13:15
  • The router model is TL-WR841N. How would you "clear all network settings"?
    – freakout
    Jun 6, 2013 at 13:18
  • Observation Jun 15, 2013 at 17:36
  • Same problem on a completely new iMac - delivered with 10.8.3 - updated to 10.8.4 a few days after the migration from an older MacBookPro without any error message - maybe the more or less "old installation" or some artifacts caused the problem?
    – user51423
    Jun 17, 2013 at 20:33
  • On a older MacBook I had similar problems. Turned out to be interference between Bluetooth and WIFI. In the end I set a different channel for Wifi and it worked well. Disabling Bluetooth also worked. Might be worth a shot...
    – bdecaf
    Oct 8, 2014 at 11:15

2 Answers 2


Since the update told you it failed, you might need to re-apply the update by connecting to a wired network or downloading the whole update from another computer if yours is off the network.

Be sure to download the 10.8.4 Combo updater and re-apply the update to be sure the drivers all installed properly and no pieces of your software were missing or corrupted. Since normal updates are a delta (only the changed items get written), it's a slim chance that something odd happened and a re-install of the patch might help fix things up for you.

Once you've gotten the OS X update installed, should the problem persist, you can troubleshoot it as normal. The two avenues I would pursue to troubleshoot this would be to dig into Wireless Diagnostic first to see if it can identify your issue.

  • /System/Library/CoreServices/Wireless Diagnostics.app

This tool is substantially better on 10.8.4 than it was on previous versions (when it was called Wi-Fi Diagnostics) and it has helped me solve several tricky network issues already.

The second would be to go into the Network preference pane and clear all known wireless network settings:

  • Network Preference Pane
  • Wireless
  • Advanced
  • Delete all preferred networks
  • Then make a new "test" location and try re-joining the affected network (or joining another network to ensure this isn't just a coincident failure of the wireless card and not related to the update)
  • Thank you bmike! I will try that. In the meantime I have looked up the log files and discovered that the update error was because of an outdated version of Little Snitch. I forgot to do the last LS update.. For testing purposes, I removed LS now and try to reinstall the update.
    – freakout
    Jun 6, 2013 at 13:50
  • That program kills more network connections than I can care to count. It often prevents DHCP responses and even DHCP requests from going out - rendering your network totally dysfunctional. It's a nice app - but required advanced knowledge to troubleshoot and often causes failures that are hard to even diagnose.
    – bmike
    Jun 6, 2013 at 13:54
  • 1
    I removed Little Snitch and installed the update again. Everything works great now! Thank you @bmike!
    – freakout
    Jun 6, 2013 at 14:43

i have the exact same problem except that the installation of 10.8.4 went fine. i also installed the combo to make sure. my MBA refuses to connect to any WPA2 router. I tried 3 different networks and it is always the same issue. When I remove WPA2, it connects fine.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .