My imac bluetooth keyboard had some keys broken so I bought an anker keyboard.

It's the one mentioned in this review:


My problem with it is the same as the problem #1 in the review, the keyboard doesn't have a escape key.

The place where esc should be is an empty box symbol which you can see in this image:

enter image description here

You have to press fn + box to escape. I'm trying to remap it with KeyRemap4MacBook but I can't figure out how. The review mentions that it should be possible. Any assistance is appreciated thanks.

  • I have a similar keyboard, and Fn+HomeIcon keys is indeed Escape.
    – user93898
    Commented Oct 8, 2014 at 3:44

3 Answers 3


Err, that's an iOS keyboard... (and the key is a Home button)

I would say that your easiest bet would be use use PCKeyboardHack (or KeyRemap4MacBook) to use the caps key was escape. I use this on my mac, as caps is normally useless anyway.

How to Change

  • Note that Escape's code is 53
  • Locate "Change Caps Lock", double click the key-code there, and to edit to 53

PCKeyboardHack Screen Shot

  • thanks i'm trying to figure out the remapping. Is this correct: cl.ly/image/1Z0a3P182a1t It's not working?
    – Harry
    Commented Jun 5, 2013 at 23:34
  • @Harry (I'm assuming you are taking the caps route) Note that escape's code is 53, then scroll up and to where you should see "Change Caps Lock" and double click the key code there to edit to 53
    – demure
    Commented Jun 6, 2013 at 0:43

The fn+home key combination works as Esc.

  • 1
    I just wanted to add that the fn + home key does NOT function as ESC. I have a white version of this keyboard (or quite similar one, certainly same manufacturer).
    – user66459
    Commented Jan 4, 2014 at 21:29
  • Agreed, it doesn't. Commented Oct 22, 2015 at 10:04
  • 1
    It does work if it is paired to an iOS device..
    – chicken
    Commented Apr 18, 2016 at 9:23

iOSKeyboardEscapeKeyEnabler will enable the home button on the keyboard to function as an escape key.

For some reason Karibiner is unable to read the key, possibly due to it being part of the "Consumer" page and not the "Generic Desktop" page.

  • This solution worked for me in the end! I had to disable the SHA check for brew install but it worked!
    – aubreypwd
    Commented Aug 24, 2020 at 1:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .