3

The firmware update 1.0 for my MacBook Air (2012) is not installing. I do not have the disk encrypted and I have tried an SMC reset. I also let the mac sit for a minute after shutting down before turning it back on just as the update suggest. Every time I boot my air back up it tells me in the App Store that there is still an update that needs to be taken.

Any suggestions?

4
  • 1
    This may potentially have helpful info: apple.stackexchange.com/questions/91555/… – bassplayer7 Jun 2 '13 at 0:07
  • Already had a look at that. Nothing in there helped. I may try a reinstall soon. – James Manes Jun 2 '13 at 1:47
  • @JamesManes have a look at it again. It clearly states in one of the answers that you have to disable FileVault to update the firmware as it modifies files in /system and /system is not available when the update starts as your volume is encrypted. (I am sorry if this sounded offensive in any way to you. I had no intention of offending you at all) – Chrisii Jun 2 '13 at 10:20
  • Have a look at my question again. I clearly stated my disk is not encrypted therefore I am not using FileVault. – James Manes Jun 2 '13 at 19:28
0

Do you happen to have FileVault enabled? If so, you cannot update the firmware on the drive at this state.

The firmware update happens before the OS decrypts/unlocks the drive, thus at FW update time, the drive is not accessible.

The only solution I know is a bit of a pain:

  • turn off FileVault
  • run the update
  • turn FileVault back on
1
  • FileVault was not enabled. I tried everything I could find. I did a fresh reinstall and it fixed the issue. – James Manes Jun 2 '13 at 19:28
0

File Vault was not turned on and I could not find the cause. I did a reinstall and tried the update from a new install of OS X. The update took and all is well. Perhaps it had something to do with me having a bootcamp partition? No idea.

Reinstall worked however.

0

After several tries with the same result described above, I did a safe-restart (holding the shift key) and the firmware update began. Something other than FileVault was obviously creating the same problem.

1
  • Yes it is not filevault causing the issue in our cases. This is correct. No idea what the heck happened. Only answer is to reinstall the OS for now. Kinda sad considering this is what I would expect from Windows XP. – James Manes Oct 21 '13 at 17:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .