6

I'm using Word for Mac 2011. When using the default font - Cambria - extra spaces appear when I type an apostrophe followed by another character. See the screenshot at:

example

As you can see in the screenshot, the font for the apostrophe character (which includes a big space after it) isn't actually Cambria; instead, it's

MS 明朝 (Body Asian)

It seems that Cambria automatically uses this font for apostrophes, and that the apostrophe character for this font includes the extra space.

How should I go about fixing this so that apostrophes appear correctly? I'm guessing it might be some kind of font conflict, but I'm not sure: and I don't know how to fix font conflicts, in any case.

(Originally posted at https://stackoverflow.com/questions/16873412/incorrect-apostrophe-character-in-ms-word-2011-on-mac)

  • Cambria is one of many font families installed by Microsoft during the Office 2001 installation. It sometimes installs them in ~/Library/Fonts folder, as well as in /Library/Fonts/Microsoft. You may have other copies of this font elsewhere, too. One first step is to run Font Book to find duplicate copies of this, and other font families. Select the All Fonts category in the left-most pane, then execute the Edit menu > Look for enabled duplicates. You should also search for Cambria and then execute FIle menu > Validate Font and File... Report back with results and info on your Mac & OS version. – IconDaemon Jun 1 '13 at 15:21
  • Hi, and thanks for this! I'm on a current-issue MacBook Air with OS 10.8.3. When I run "Look for Enabled Duplicates ...", Font Book tells me that "There were no duplicated fonts found on your system". Likewise, validating font for Cambria doesn't throw up any problems. I'm not sure what "Validate File..." is supposed to do; it opens a dialog box that looks like it wants me to select a file, but I'm not sure what that file would be ... – Jim Jun 2 '13 at 11:41
  • It may not be a duplicated font problem, then, but it won't take but a minute to eyeball the other paths I mentioned to see if Cambria lurks somewhere. You also didn't mention that you'd checked Preferences > AutoCorrect to make sure the 'AutoCorrect', 'MathAutoCorrect', 'AutoFormat as You Type' and 'AutoText' tabs settings are 'normal'. In the AutoFormat AYT tab, have you unchecked "Straight quotation marks with "smart..."? Lastly, try zapping the Office Font Cache which is here: ~/Library/Application Support/Microsoft/Office/Preferences/Office 2011/ – IconDaemon Jun 2 '13 at 22:42
  • I've checked Preferences > AutoCorrect and everything seems "normal", although I'm not quite sure what normal should look like! Unchecking "Replace straight quotation marks" does fix the problem, but I'd like to have smartquotes working. There don't appear to be any Cambria variants in ~/Library/Fonts. I've deleted the cache (and "Word Font Substitutes") but when I relaunch word the problem is still there, and the files have been recreated. Any other tips greatly appreciated! – Jim Jun 4 '13 at 13:12
  • I suggest you 1) run the Office 2011 installer & re-install just the fonts, 2) make sure you've updated Office 2011 to the latest versions (run /Library/Application Support/Microsoft/MAU2.0/Microsoft AutoUpdate.app). You could also experiment by creating a new user account, logging in, and testing Word to see if the problem goes away. If it does, then it is something unique to your account. – IconDaemon Jun 4 '13 at 20:58
3

After updating OS X to 10.9 and opening Word for the first time since the update I encountered the same problem. I spent half a day testing all the suggestions put forward here and in other forums responding to the same query (including checking autoformat preferences/searching for font duplicates/verifying fonts/testing in new mac user account/repairing permissions etc.) with no luck.

Finally, I deleted the Cambria font from the Font Book and reinstalled again. I reopened Word and tested and the problem seems to have disappeared.

I'm using OS X 10.9 and Word for Mac 2011, v14.3.8.

  • Thank you so much, @Jawa, re-installing Cambria fixed it! At last!! – Jim Nov 23 '13 at 15:48
2

Normally you would not expect this kind of thing (font substitution) to happen unless your default font had no character for the Unicode curly apostrophe. Is it possible you have an old, non-Unicode (e.g. Postscript) version of your font installed that is being used by mistake?

PS I have found a reference to this same problem in the MS Forums from 2011. Perhaps it will help:

http://answers.microsoft.com/en-us/mac/forum/macoffice2011-macword/normal-template-is-using-asian-font-for/d79e850a-8df0-4540-bc93-cf3901b7cd99?msgId=54e54894-ebbb-4764-845d-35785d362b40

  • Cambria, Cambria Bold, Italic and Cambria Bold Italic are all TTF files. Does this mean the fonts are Unicode? Thanks for your help! – Jim Jun 2 '13 at 11:48
  • Yes, I think so, assuming it is version 5 or up at least, and you have no other Cambria fonts hiding somewhere. – Tom Gewecke Jun 2 '13 at 14:38
1

Is your OSX Language & Text setting set to something other than English? (I'm guessing that it IS set to English, based on your screenshot.)

It's possible that Word's default language is not set to English (US) (or your English-speaking country of choice). Ensure that it is set to the correct language by opening any document in Word, then go to Tools/Language, select English (US) (or whichever English variant is appropriate), then click the "Default" button and verify the change to the Normal.dot template. Then, create a new document and type text that includes an apostrophe, and report back on the result.

Reference: http://answers.microsoft.com/en-us/office/forum/office_2007-word/extra-space-after-apostrophe/13edb10b-6a5f-464e-8f33-0b41c63c4680

  • OSX Language & Text is set to English, and Word is set to English (UK). I'd found that reference, and tried everything it suggested. Thanks though! – Jim Jun 2 '13 at 11:45
1

Two options for the unsophisticated that worked for me:

  1. Under Word > Preferences > AutoCorrect > Replace as You Type unselect "'Straight question marks'" with 'smart quotation marks'". Unfortunately, this leaves you with straight quotation marks and apostrophes.

  2. Use Calibri as your font while writing, then convert everything to your font of choice when you are done. Unfortunately, this can be a pain where you are trying editing a document or finalizing the spacing.

I did not have any luck with adding all the word fonts to font book or with changing the proofing language.

1

I solved the problem by: home menu -typography --tick the box saying AV with an arrow above and an arrow below, pointing in different directions (switch on kerning).

I don't know what other problems this might cause elsewhere in my document, as Word is a mystery at best.

0

I've seen this problem and the cause turned out to be that Cambria was simply turned off in FontBook. I fixed it by highlighting all the fonts in FontBook, enabling them and then resolving any duplicates it caused.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .