With Mountain Lion and Safari 6, there is no built in RSS reader and Safari prompts you to find and install one from the Mac App Store if you don't have one.

So I installed a few different RSS readers. Now when I click on bookmarks to RSS feeds from Safari, it opens the last RSS reader I installed.

My question is, how do I change Safari's default RSS reader from being the last one I installed to the one I choose? I'd prefer a direct system setting than having to install another plug-in or utility (I don't use extensions in Safari).

2 Answers 2


Further research yields this solution to the problem:


RC Default App is a (free) preference pane install that allows you to easily change what types of media are opened by which application. Although it has not been updated in a while it still works on Mountain Lion.

I think this will solve your problem. I've tested it on my own Mac.

  • If I change the default application for an xml file, and choose 'Always open with', won't that change the default app for all xml files regardless of whether they are rss or not? If so, I don't want that. I have many xml files that are not rss that I need to open in other apps. All I want to do is open rss bookmarks from Safari in one of the other feed readers on my computer (not the last one I installed). Safari recognises it is a feed whether the uri is feed:// or http:// and opens a feed reader. The only missing step is to tell Safari which reader to open.
    – Jason S
    Commented Jun 2, 2013 at 4:44
  • I've revised my answer after further research, please let me know how it works out.
    – bayendor
    Commented Jun 2, 2013 at 12:34
  • @JasonS: In RCDefaultApp pick an application for the feed URL (i.e. the feed entry in the URL “tab”); this different from setting what opens .xml files (which also accessible in RCDefaultApp from the Extensions “tab”). Commented Jun 4, 2013 at 3:37
  • Run plutil -convert xml1 ~/Library/Preferences/com.apple.LaunchServices.plist
  • Add an entry like this to the plist:

  • Restart to apply the changes (logging out and back in isn't enough)

Another option is to add a line like this to a duti configuration file:

com.reederapp.mac feed

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .