3

I would appreciate any help you guys can give me since I would really like to upgrade my laptop to Mountain Lion.

Computer: Macbook Pro 17" 4,1 (Early 2008) RAM: 4 GB RAM Hard drive: 128 SSD Hard drive Video card: NVIDIA GeForce 8600M GT Current OS: Snow Leopard 10.6.8

Steps I have taken but failed to properly install the OS.

  • Dowloaded Mountain Lion at least 3 times from the App store to make sure the download wasn't corrupted.
  • I even tried making a Lion Bootdisk so I can install Mountain Lion on a USB drive (Install ESD.dmg).
  • I have even tried installing Lion first thinking I would take it one version at a time but gets stuck on boot screen too.
  • I even changed my hard drive to a new blank SSD drive to see any difference.
  • Each time I install Mountain Lion or Lion, everything is good until the installer has to restart the laptop.
  • Laptop gets stuck at the grey boot screen with the Apple logo and the loading circle. Nothing ever happens after.
  • Even waited for 7 hours but no changes in the boot screen.
  • I always had to use/boot to the Snow Leopard CD so I can restart the laptop back to the Snow Leopard drive.

Safeboot gives me this endless message "ERROR: Firewire (OHCI) TI ID 8025 built-in: handleUnrecoverableErrorInt" but I don't have any Firewire cable connected at all.

What can I do next?

1

I'd do a quick triage to boot the Mac into single user mode to see if the boot drive / base OS is minimally functional. After that, I'd start with systematically working through the startup troubleshooting guide from Apple.

You've clearly done many of the steps, but the order of steps is very helpful in knowing what the likely cause of the problem is. I might skip removing the SSD if you don't have a HDD - but installing a clean OS onto an external HD at that point might be a good way to rule in or out your SSD as contributing to the failure to install and boot properly.

  • Thanks for reply bmike! Since I can only install and run Snow Leopard (10.6.8) I don't have access to a "recovery mode" thats only available in Lion/Mountain Lion, unless there is one pre-Lion? Each time I do a Safeboot (Shift+Command+V) I get this message. "ERROR: Firewire (OHCI) TI ID 8025 built-in: handleUnrecoverableErrorInt" endlessly. It's odd because I don't have any firewire connected to the laptop or anything connected. Heres' the steps I took w/ both normal hd & ssd - Download Mountain Lion - Install Mountain Lion - Mountain Lion restarts laptop - Laptop gets stuck at boot screen – Retrospective May 31 '13 at 21:58
  • You did say that in the text - so I've edited out the reference to Recovery HD - it's Lion or later only. – bmike Jun 1 '13 at 1:33
1

I had the same exact problem on a MacBook 13″, early 2008.

After many hours, I've come to the conclusion that my FireWire port/controller is the culprit. It's damaged and it doesn't let me install Lion (and I've had problems installing CentOS 64 bits - no problems on the 32 bits version, so 64 bits architecture might be an issue too).

To properly boot Snow Leopard (without waiting 5 minutes to boot…), I even have to remove the FireWire extensions. After that, everything works fine (except the FireWire, of course).

So, I think you might have the same problem: a faulty FireWire port / controller.

1

I'm reloading the OS on a MacBookPro3,1, and was having the same issue. I inserted a cable into the FireWire 400 port and wiggled the cable (gently) and the problem went away, so it seems like it was just some junk built up on the connector...

0

Have you try a reset of the NVRAM/PRAM ?
Sometimes it fixes mystic bugs like this.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .