1

When I edit spreadsheets in Numbers, I often hold down the left or right arrow key to get to the far-left or far-right column of a table. Numbers always beeps at me when I do this. It seems to think it is an error to press keys that try to move outside the boundaries of a table, even though the keystrokes are from keyboard auto-repeat.

This is highly annoying. How do I stop Numbers from beeping at me all the time? I know I can mute the system volume or the default beep sound, but I like to listen to music, and the beeps in other programs are sometimes useful.

1

The keyboard shortcut for going to the last cell of a row: +Right Arrow

The keyboard shortcut for going to the first cell of a row: +Left Arrow

The keyboard shortcut for going to the last cell of a column: +Down Arrow

The keyboard shortcut for going to the first cell of a column: +Up Arrow

This will save holding the arrow key down repeat extending beyond the table bounds resulting in the annoying beeping/screen flash error.

0

I don't know how to resolve this directly, but here's a work-around for the problem of the beep being annoying:

Mute the default beep sound, and turn on "Flash the screen when an alert occurs" instead. This is in System Preferences > Accessibility > Audio (in 10.8.3).

  • Well, I tried this, but unfortunately, I find the screen flash more annoying than the beep. – andrew May 31 '13 at 1:45
  • Sorry to hear that. I have two ideas: 1) investigate writing an AppleScript to move to the far-left column, and arrange to call this via a keyboard shortcut (I don't know if this is possible, sorry, but it may be worth a look); 2) give feedback to Apple about the issue at apple.com/feedback/numbers.html – Ashley Jun 1 '13 at 13:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .