4

I have an iPhone 4 running iOs 6.1.3.

I have just switched from O2-UK to T-Mobile.

O2 supported Visual Voicemail and T-Mobile does not (at present)

I have set up my voicemail by dialling 222.

However, I want to set up the diverts (no answer, unreachable, busy) to voicemail but cannot find an option for this anywhere in the Settings app.

How do I switch these on?

2

After some further googling I have sorted this now. It appears that all UK T-Mobile users get an individual Voicemail divert number. Dialling 222 for the first time should have set this up for me but it didn't.

This worked for me:

  • I completely reset all divert options by dialing ##004#
  • I then re-dialled 222 and a message said that number had been set up and I need to reboot the phone.
  • I also got an SMS with my voicemail divert number in it.
  • I rebooted my phone and sent **004*+[the number from my sms]#

My voicemail is now working as expected!

  • Great documentation. I'll edit in UK on the presumption that the various T-Mobile operating companies don't all share the same back end hardware. – bmike May 29 '13 at 17:57
1

You could go to the settings app and turn on "Do Not Disturb" and see if the carrier would divert things once you don't pick up each call.

If so, you could then review the settings under Notifications to ensure you get calls from Favorites (or not) while the settings are in effect.

Most carriers also have a number you can call to configure call forwarding. On AT&T in the US, this used to work…

  1. Dial *#67# to see which number is used to forward calls to voice mail
  2. Dial *21*number# to forward all calls unconditionally
  3. Dial ##002# to restore the normal incoming call behavior
  • Feel free to edit this to reflect how T-Mobile in the UK sets up call forwarding, I wasn't able to find it in a brief search of the internet. – bmike May 29 '13 at 15:58
  • With "Do Not Disturb" enabled it just rang and rang and rang, till I gave up and hung up. – Shevek May 29 '13 at 16:05
  • *#67# responded with multiple options for Busy, all set to Disabled – Shevek May 29 '13 at 16:06

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .