I've frequently used Special Characters, accessed with Command ⌘+Option ⌥+T, and have been able to insert characters into text fields by double-clicking them. However, this has stopped working. I can still bring up the Special Characters window and navigate through it, but double-clicking an entry only adds it to the Recently Used section - it doesn't actually insert them into the focused text field. The window also seems to act as if it's not in focus, as the various UI elements inside the window are highlighted with grey rather than blue. Clicking inside the window does not focus it, and clicking on the title bar only focuses the title bar, and not the rest of the window, as can be seen below:


Do any of you have an idea as to what might be the cause of this? As far as I'm aware I haven't changed anything between when it worked and when it stopped working.

  • Have you rebooted since this issue started?
    – demure
    May 29, 2013 at 14:46
  • Yes, several times.
    – jrtc27
    May 29, 2013 at 14:48
  • In what application? 2nd question: did you recently install application or made changes to the shortcuts?
    – Ruskes
    May 29, 2013 at 16:15
  • 1. Any, be it Safari, Skype or simply TextEdit. 2. As I say, I can't think of any changes I've made.
    – jrtc27
    May 29, 2013 at 16:20
  • i think Gray is normal for Character Viewer, not blue. Set up a new user acct and see if it works there. If yes, you probably need to trash a .plist in Home/Library/Preferences. May 29, 2013 at 21:18

2 Answers 2


I had this exact same issue, and user Tom Gewecke's advice seems to have fixed it for me. I simply removed two plist files in ~/Library/Preferences, and then rebooted. The files were com.apple.CharacterPicker.plist and com.apple.CharacterPaletteIM.plist. I don't know which of those files had the issue, but after removing them and rebooting they've regenerated, and everything's good again.

If you're comfortable with Terminal

You probably know how to move files around, just move these two somewhere else, or rename them:

  1. ~/Library/Preferences/com.apple.CharacterPaletteIM.plist
  2. ~/Library/Preferences/com.apple.CharacterPicker.plist

If you just want something you can copy and paste, here you go:

mv ~/Library/Preferences/com.apple.CharacterPaletteIM.plist{,-backup}
mv ~/Library/Preferences/com.apple.CharacterPicker.plist{,-backup}

Reboot after this, and fingers crossed, it will work for you again.

If you're not so comfortable with Terminal

Open up a Finder window and press Shift ⌘ G (Shift Command G), then type ~/Library/Preferences/, and press Enter. There will be many files in that folder, you're looking for the ones called com.apple.CharacterPaletteIM.plist and com.apple.CharacterPicker.plist. When you find them, you can probably just remove them, but it's always a good idea to back them up. Just move them to another folder or something.

When you've done that, reboot your computer, and see if the Special Characters window works again.


Are you opening /System/Library/Input Methods/CharacterPalette.app/ directly? If it is opened directly, double-clicking doesn't seem to insert characters.

In any case, you could try running killall CharacterPalette or opening the character viewer from the input menu instead of the menu bars of applications.

Characters can also be inserted with drag and drop or by selecting Copy Character Info.

It's normal that the whole window appears gray, because it isn't a key window. And it's normal that the background of selections is gray instead of blue, possibly to indicate that the views don't support keyboard navigation or multiple selections.

  • 1. No, I'm not. 2. It's not running. 3. Drag and drop doesn't work - I can drag, but it doesn't insert on drop. 4. I am aware of the Copy Character Info - I currently have to resort to that.
    – jrtc27
    May 30, 2013 at 17:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .