I've tried to use Ubuntu on my macbook pro (6,2), but it was a total and abject failure, mainly due to poor hardware support.

So, I have given up on my little experiment and just deleted ubuntu and erased the partition it used in the ssd. Now, I'm trying to make os x reclaim the former linux partition's space, but I get an error whenever I try to resize the system partition in Disk Utility:

Partition failed with the error:
File system resize support required, such as HFS+ with Journaling enabled.

OS X's partition is "Mac OS Extended (with journaling)". My OS X's version is 10.8.3 (Mountain Lion).

Any way of doing it without wiping out the disk? Even if I had a backup one, the bakcup-and-restore process would be very time consuming and I believe there must be a cleverer way of resizing a partition than deleting everything...


output of diskutil list:

   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *240.1 GB   disk0
   1:                        EFI                         209.7 MB   disk0s1
   2:                  Apple_HFS osx                     40.0 GB    disk0s2
   3:       Microsoft Basic Data Deposit                 139.7 GB   disk0s5
  • Are you sure you are resizing the correct partition? Could you provide the output of df and a screenshot of your SSD partition map as shown in Disk Utility? How do you try to resize your system partition, from the command line or using Disk Utility? In the former case, which command and options?
    – jaume
    May 29 '13 at 12:36
  • I'd say diskutil list would be a good place to document what you have to start. You might even need to get more detail into the question, but if the Apple tools aren't working, you might need to use the Ubuntu tool (or another disk partition utility to undo the changes it made).
    – bmike
    May 29 '13 at 13:44
  • Maybe, I didn't emphasise enough, but I'm using disk utility to resize the system partition (I even tried to do it from an os x install disc, and it didn't work either). I'm trying to resize the correct partition. My disk has only 3 partitions: EFI boot partition (a few dozen megs), os x's partition and a fat32 partition that was shared by both os x and linux for bulky storage. May 29 '13 at 14:18

The real reason may be the fact, that the recovery partition is no longer there.

Have you tried the resize with diskutil command? (man diskutil look for the resizeVolume command). If nothing else, it might give you a different or better error message.

A repair on the volume might also help.

Also see this question.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .