4

I am using Google Calendar on an up to date iPhone 4S. I also use my iCloud calendar.

When I create an event in the Google Calendar in iOS's calendar app, the event is only visible on the iPhone. It does not get synced to the Google web app or my Mac. When I create an event on the web app, it gets synced to the iPhone.

Using the iCloud calendar works fine both ways.

What might be the problem? I've tried to disable the calendar syncing, and re-enabling it, but that did not help.

  • Update: The same problem persists with my iPad. – Arne May 29 '13 at 16:19
  • It seems the iPad event was synced after all. But it took many minutes. Will try to test further on all devices. – Arne May 29 '13 at 16:52
3
+50

It often takes a few minutes for the cloud to sync, that's normal.

I'd suggest double checking your phone to ensure your push settings are all set the way they ought to be. Since it's working on iPad, but not iPhone, it's my assumption something got funky in the settings and it's simply not being pushed to the cloud.

easiest fix, delete your gmail and redo it, or compare each item on your phone to your iPad.

Also, a restart my help as they get silly sometimes.

  • I deleted the Gmail account from my iPhone and re-added it. Will try and see if this helped. – Arne May 31 '13 at 14:37
  • Well, I'll be... This really worked. After deletion and re-adding of my Gmail account, new events are now synced to my Google calendar. – Arne May 31 '13 at 14:38
  • Happened to me in the past too, glad it helped! – Ryan Hollingsworth May 31 '13 at 15:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .