3

I have a 13" late '11 MBP OS X Lion 10.7.5 I am trying to hook up to my LG HDTV with a Thunderbolt HDMI cable. Getting the display onto the TV is a snap. The audio, however, is not working. The thing I'm noticing is in the Sound tab the TV is not an option for Sound Effect, Output, or Input, only internal speakers and aggregate device.

I have updated my software, reset SMC and PRAM, gone to Audio MIDI Setup (where the TV isn't optional), plugged the Thunderbolt in while the TV was off/on, etc. Can someone tell me why the TV is not appearing in the Sound options?

  • 1
    Did you try a different cable and/or verify that your setup works with another TV? – nohillside May 28 '13 at 5:04
  • Agree, sounds like cable problem :( If you have VLC player try it and select HDMI as output in VLC menu. – Ruskes May 28 '13 at 6:08
  • I'm having the same problem and it's frustrating because the answer I got from apple was that I have been on websites that have bugs that entered my computer, so they are transferring through the thunderbolt wire to the hdmi input in the TV and I need to go pay to have it debugged and I won't have this problem with the audio anymore. The display is fine so I don't even see how that would be the issue. – user52828 Jul 7 '13 at 21:24
  • I've connected my MBP (15inch 2016) using a Thunderbolt 3 to HDMI Adapter from Sonnet (it has dual HDMI 2) sonnettech.com/product/thunderbolt3-to-dual-hdmi-adapter.html , yet when I look at the sound in the system preferences it says DisplayPort against the external monitor. This is crazy! Connecting it to a Samsung U28E590 – JGFMK Apr 18 '18 at 18:41
6

That model of MBP supports audio through that adapter, so you should be getting sound. It could be any number of things. I think your problem is on the TV side, but Here are a bunch of things to try:

First, make sure you're connected to your TV and getting an HDMI video signal to the video input you've selected.

Go to your MIDI Audio Setup again and make sure that your thunderbolt output is set to "Use this device for sound output." Highlight it, and go down to the setup (gear icon below) to set it.

From your Apple Menu, open your System Preferences and choose Sound. Try setting your "Use audio port for:" to Sound Input, as it may be hogging the audio out channel and not letting your thunderbolt use it. Make sure your system volume is turned up there too.

If you have various sound drivers installed and showing up in Audio MIDI Setup, just leave them alone for now, and DO NOT use any aggregate devices. Select your thunderbolt output and make sure the volume sliders are turned up. You should see the speaker icon next to that audio output selection too. We're not interested in "Sound Effects" in this case, so don't worry about that.

Recheck ALL your connections.

Make sure your volume is turned up on the MBP.

THe content you're trying to play probably has a volume control of it's own too. Make sure it's turned up.

And make sure that your TV volume is up, and not accidentally on Mute.

IF your TV's set up to play audio through your amplifier (surround, etc.) make sure your amp is on, set to TV as it's input, and volume is up. Don't turn these all up to max! When you find the culprit, you don't want to blow anything out.

Make sure your TV isn't in SAP mode.

Check to make sure you don't already have an audio source plugged into the audio jacks for that input on your TV. HDMI only on that TV input.

Check the setup options for Audio in the app you're using to play your content. If it's a movie, for instance, and you're using VLC as your player, check your Audio Device setup in the Audio menu option.

Make sure your TV isn't setup to expect audio from it's Stereo input jacks, as if you were connecting via component video and audio. Light up the menu options on your TV, and just double check your Audio options settings. Maybe that input port on your TV is pre-set to expect only separate stereo jacks on that input. Just a thought. You might try another HDMI input on your TV just as a test.

Try a different HDMI cable if you've got one.

That's all I can think of. I have a feeling one of these will solve the problem.

  • Does it also support 5.1 channels through the adapter? Where did you find this information? – pete Jul 6 '15 at 23:52
0

I have had the same problem but I put the adapter in my iMac and both sound and display worked. The adapter manufacture support (StarTech) said it was my MacBook Air's thunderbolt port and I should take it to Apple to check out.

Wait till I tell you what I did and got it to work. I have bootcamp set up so I booted my MacBook up on the Windows side and it worked perfectly. Now that I know that the port is good I still do not know why it will not work on the mac side of my computer.

0

I had the same problem. went to system preferences, open sound, output, selected my samsung tv as output and it instantly switched sound from laptop to tv.

0

Some monitors don't have speakers, when plugging into the two I have, there is no option to send audio through to the monitor; on other television monitors the option is there. The OS X sees the monitor and calls it by name, so there must be something in the return signal sent from the monitor that "tells" the OS if it is capable of audio.

0

Using the Sound Setting in System Preference solved the problem. Once the HDMI is plugged between the adapter and the TV, a new option shows up in the Sound setting. I think it says "Use TV as sound output", then choose that. The sound control transfers to the TV (but you can't control Audio in Mac in this setting, it's disabled). Of course, you will use the TV remote from here on.

0

After all these years, most the above answers are wrong. He has NO OPTION for his TV in the Sound Tab Output when he plug the TV. If his TV was showed up on the Sound Preference then it's another case

But gmacd77 share some green light there. Not sure did he finally managed to get it working under OSX

I have exact same problem. I've tried 4 adapters, 2 TVs and test with 3 Macs.. everything works normally Only my MacbookAir6.2 under OSX are having this Issue

  • I've been having the same issue - two macs in the room, one a 2013 macbook air I've tried with various adapters and no hdmi audio shows up. On a 2012 macbook pro, using the same adapters but in Linux not OSX, I can play the audio just fine. – Stuart Axon Apr 7 '18 at 20:07
-1

System PreferencesSoundSamsung HDMI is the solution.

-1

"System Preferences → Sound → Samsung HDMI is the solution."

This got downvoted but it actually worked for me.

System preferences, sound, selected tv. Then it didnt work and I raged a bit. THEN i realised I had to click on "Output Sound" which opened a new tab. Then i clicked select output sound and then clicked on my Tv. Worked.

I was happy about it because this problem has been pissing me off for a while.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .