I have mac mini mid 2011, bought 14 months back. Yesterday I started my system normally but it was running slow the usual so I restarted it, after restarting system was taking too long to boot but this time it did not show the login screen and stop sign or crossed circle appeared in place of apple logo.

I again restated the system and keep holding option key to use disk utility and recovery-hd(actual name in my sys is recovery-10.8.2) but recovery also didnt worked, after selecting recovey-hd same happen system keep booting too long and stop sign appear on apple logo.

I have bootable mountain lion usb, I get into disk utility check the hard drive by running verify disk and got no issues.

I have 3 partitions

  • Macintosh HD (os installed in this) 200gb
  • Macintosh HD 2 (I keep my important files in this) 200gb
  • My TimeMachine (I use this for time machine backup) 100gb

I decide to format Macintosh HD and to install mountain Lion again so I started to format this partition, but again after approx 25% formatting got stuck, after restart I also delete the partition and then tried to format but formatting got stuck in middle. I restarted the system and read searched on Internet regarding this issue, some saying hard drive crashed, same saying fan not working but both are fine in my case.

I created a bootable ubuntu on another usb and boot the system from ubuntu, then I tried to delete and format partition using gParted Partition Editor but after too long operation failed message appeared (now I am worried).

I keep searching on Internet regarding this issue and found that this happens when Master Boot Record gets corrupt. And thats why nothing can be write on disk(brief description).

Please help me what actually happed and how to fix this issue?

  • If its a Mac mini 2011, then its an Intel processor. That means the disk was NOT formatted using Master Boot Record. Intel Macs require GUID partitioning, or they won't boot. It sounds more like the hard drive is failing. Your need an external drive, either Firewire or USB connection. Format the external drive, install the OS, and copy as much of the data as you can. May 28 '13 at 3:37
  • You've gotten three different OS to error out on the storage. Save whatever files you care and then wipe that drive totally. If you are lucky, it's fine but I would expect is to be hardware failure from the inability of the OS to self-repair.
    – bmike
    Nov 29 '13 at 6:15

Two possible problems IMHO:

1) Faulty disk, bad blocks on it.
2) Corrupted GUID (usually mac disks aren't formatted with MBR)

Possible check/solutions:

1) How to check for bad blocks without formatting.
2) View my answer here.

However, if you can provide an exit error number while trying to format disk with disk utility it's easier to identify the exact origin of your issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .