I've been running an Open Directory environment for over a year now, and this issue has never, ever stopped plaguing my network. Users constantly have syncing errors, seemingly due to permissions issues. In this case its an iTunes file, but it has been anything from an .xls on the desktop, to items in the library.

Does anyone have an idea on how to resolve this issue?

Right now the only way I can get rid of the sync issue is to log into the server (running the latest Mountain Lion with OS X Server), navigate to the home folder of the particular user, and delete the file myself.

This is obviously an awful experience now that we are growing in terms of users :(

At a basic level, we're using an OD setup via Server.app and tuned with Workgroup Manager.

The hardware is a Mac Mini (Mid 2011):

Processor:2.3 GHz Intel i5
Memory:   8 GB 1333 DDR3
Software: OS X 10.8.3 (12D78)
Server App: 2.2.1 (12T162)

# of Users varies between 2-6

Client Machines

Mid 2011 iMacs
2.5 GHz i5
4 GB 1333 DDR3
OS X Lion 10.7.5 (11G63)

Server Error:

Server log error: May 21 12:06:26 server.name.com sshd[20492]: Authentication refused: bad ownership or modes for directory /Users/nickrossi/Library/FileSync

Server log error: May 21 12:06:26 server.name.com sshd[20492]: Authentication refused: bad ownership or modes for directory /Users/nickrossi/Library/FileSync

Server log error: May 21 11:52:41 server.name.com sshd[19924]: Authentication refused: bad ownership or modes for directory /Users/brockmantella/Library/FileSync
    swupdateServiceLog = "/var/log/swupd/swupd_syncd_log";

enter image description here

  • You should really take a good look at the log files on your server to see what kinds of errors occur when the syncing goes south. For more help from the experts here, we need to know what hardware ML Server runs on, the number of clients, and other details about your server setup and network topology.
    – IconDaemon
    May 21, 2013 at 15:50
  • I'd be happy to add more network-oriented details, but what exactly would help? I'll begin going into more detail. Check edits for hardware, errors at this point in time
    – CDD
    May 21, 2013 at 16:13
  • Are you setting up your Mobile Homes using Profile Manager or the older Workgroup Manager process?
    – bispymusic
    May 21, 2013 at 16:37
  • Originally setup via the profile manager under server.app, but I believe i have edited a few things via Workgroup Manager
    – CDD
    May 21, 2013 at 17:39
  • Is this still something you face on some accounts or was it a temporary burp where a bunch of files failed and then things work once you cleaned up the conflicts?
    – bmike
    Nov 25, 2013 at 19:54

2 Answers 2


From: http://unixsystems.blogspot.com/2012/06/fixing-ssh-daemon-authentication.html

If you see something similar to:

sshd: Authentication refused: bad ownership or modes for directory /Your/Home/Path

You have a home directory permission problem.

change to that user if not already one and execute:

chmod go-w ~/
chmod 700 ~/.ssh
chmod 600 ~/.ssh/authorized_keys 

It will restore your permissions and you should be able to connect.

  • chmod 700 was fine, but the following failed? sudo chmod 600 /Network/Servers/server.name.com/Users/nickrossi/.ssh/authorized_keys \ Result: No Such File or Directory
    – CDD
    May 21, 2013 at 17:24
  • note - also tried the command while under a normal su/switch user (in this case, nickrossi). Still no such file or directory?
    – CDD
    May 21, 2013 at 17:33
  • Perhaps the .../authorized_keys directory doesn't exist at this point in time because it couldn't be created in the first place because of permissions issues. You could jump in and create the directory manually, (making sure you get the permission correct,) but you might want to see if the server/client mechanism creates this directory when the user logs in.
    – IconDaemon
    May 21, 2013 at 18:01

I'd like to start with my network homes and mobile homes mantra.

How To Set Up Mobile & Network Homes

1/ Are you sure this is the best solution to your problem?

2/ Are you really sure?

3/ Then use network accounts unless absolutely forced to use mobile ones because someone has a laptop. If they have a laptop allow them and only them to be a mobile rather than network account.

3/ Are you ABSOLUTELY sure this is the only way to solve your problem?

4/ Put your network home folders on a separate drive to the OS, preferably on their own. If you must have them on the same drive as your OS put them totally outside the Apple file hierarchy. Curse your cheapskate boss for not spending $100 on another drive to put them on.

5/ Share the volume out using a single protocol. This is the one time that AFP may well be better than NFS or SMB.

6/ Place a large bottle of your favourite spirit next to the hard drive used for network homes.

7/ When you get complaints about login speed, application speed and weird errors in Office or Adobe applications share a quick snort with the user and tell them to live with it.

8/ Are you positive you want home folders stored over the net?

9/ Make sure your Server and all your clients are running exactly the same version of the OS.

If you abide by the mantra almost all of your problems should go away, apart from Office and Creative of course but you knew that.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .