0

Acquired a 13" Retina liquid damaged - Apple Certified Tech. Trying to salvage.

Haven't disassembled yet to see the extent of the liquid but it boots and runs. No liquid spill indicators triggered.

Battery is recognized but in "Replace" mode and does not charge or function. Boot time is slow, run time is slow.

Activity monitor shows that CPU's are "swamped" in the 85% to 90% range at all times with nothing but the O/S installed. Primary usage is pegged to Kernel Task.

I am seeing some posts that this could be battery related? I disconnected the battery yesterday but there was no change in CPU usage.

I am also wondering if it is possible that there is a security software that has been activated that is looping causing the CPU's to to load up. I got this from an Apple employee but I suppose it's possible that it has a dark past.

Have tried Safe mode, no change.

Anyone?

Thanks.

John

1

I'd suggest running AHT to check the temperature sensors are giving within-range results.

An Apple Certified Technician will also have access to ASD, which should give a more thorough test.

  • Thanks Ashley, flies through AHT only throws off a BAT (battery code) for the non-functioning battery. I'm in the netherworld of Certified. Independent of AASP I only have Service Source access, not GSX, and no ASD access. Sort of the bastard child. – John Boggs May 22 '13 at 12:49
  • Hi @JohnBoggs - netherworld sounds entertaining! Two ideas come to mind, then: 1) boot from a known-good drive to isolate whether software is the issue (you mention security software as a possibility); 2) book a Genius appointment at an Apple Store and see if they'd be willing to triage the issue for you, or at least run ASD... ... I mentioned temp sensors because I read somewhere that kernel_task would use up CPU cycles (in such a way as to generate minimal heat) if the temp was too high... but I don't know how true that is... – Ashley May 22 '13 at 18:38
  • Thanks Ashley, had it to an AASP, happy to install a replacement logic board for me for $1200-passed on that. The keyboard input is really "laggy" also so I suspect there is "crud" in the keyboard and in the battery-although none is visible. I suspect someone tried cleaning it a bit already as I found a dreaded rice kernel (no kernel panic jokes please) wedged behind the HD caddy. Don't get many Retina models yet and my son the photographer would love to have it if I can get it going right. I'll see if I can get one of my buddies at Applestore to run the ASD for me. Thanks. – John Boggs May 23 '13 at 3:26

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .