So my usb drive is stuck on read only and I have tried many different options which I have gotten from different websites.

I have tried to restore/erase in disk utility but the options are greyed out. I have also tried entering recovery mode and erasing the USB drive from there but with no luck. I have also tried using macfuse (with NTFS-3g installed)however without any success, but I am happy to try this option again if anyone has some ideas on how to do it as I wasn't to sure what I was doing and I was really just copy and pasting codes.

The USB is formatted as a MS-DOS (FAT32) if that helps.

Its really annoying because I cannot erase or edit or delete or do anything with any of the files. I do not mind if fixing it means I lose all the data.

Sorry if this is on the wrong stack exchange website, i'm pretty new to it all.

I have also tried turning my computer on and off again if that helps.

Thank you very much guys.

  • 2
    Some USB keys, (older ones, usually,) have a miniature write-protect switch built into the case. Could this be the issue? (I hesitated to mention the obvious, but no ridicule is intended.) Also, have you tried to format this USB drive on a Windows machine? – IconDaemon May 20 '13 at 11:35
  • Wish it was that easy. How would I format it on a windows? Ive never really used windows and would have no idea of how to do it. – Jamesg May 21 '13 at 8:32

Plug the USB drive into any Windows computer.

Navigate to "My Computer" in Windows Explorer (click Start->My Computer[near the top right of the window]).

Right-click on the USB drive:

  • Windows 7:
    • Should be listed under "Devices with Removable Storage"
  • Windows XP and older:
    • Should just be listed in a list of all drives installed on the computer

Click "Format".

Choose options you want to format as, make sure the "Read Only" button is deselected, and make sure the "Hidden" button is also deselected, and click "OK".

Congratulations! Your USB drive has now been re-formatted. You (should) now be able to format it using Mac OSX.


You can format from a startup disk Read this and try first: http://support.apple.com/kb/ts2176

Or format from the terminal (warning you better know which drive you are working with before you do this) Try this if the first thing doesn't work: https://developer.apple.com/legacy/library/documentation/Darwin/Reference/ManPages/man8/diskutil.8.html

  • The link for diskutil is gone now – Canadian Luke Mar 18 '18 at 23:37
  • Fixed the link. Happy Day! – ArchonOSX Mar 22 '18 at 15:45

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .