2

I have an iMac, iPad, a MacBook Air, and an iPhone.
I want iMessages to work only on the iPhone. How can that be accomplished?

3

On the Macs, in Messages.app, go to the menu Messages > Preferences, select the Accounts tab, select your Apple ID in the column on the left (if it is there) and press the '-' button to remove it.

On the iPad, go to Settings, Messages, and turn off the iMessage switch there.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .