3

Running Mountain Lion 10.8.3 I find that after a recent reboot my Favorites have all disappeared from the sidebar in Finder.

Finder > Preferences > Sidebar shows a number of boxes against Favorite folders, but these can not be selected

2
  • Try deleting the preferences with rm ~/Library/Preferences/com.apple.Finder.plist; killall Finder. Does Console.app show any relevant log messages?
    – Lri
    May 19, 2013 at 15:26
  • Do you have the same question, but 9 years later? See apple.stackexchange.com/q/450169/17600, which asks about macOS 12. Nov 7, 2022 at 6:46

4 Answers 4

5

This could be due to having collapsed "Favorites" inadvertently.

Try simply hovering over the heading "Favorites" in the sidebar; the collapsed arrow will appear: ">"; click on it to expand "Favorites"

This toggles the favorites on and off...

2
  • I had the same problem, I can't believe I didn't realise they're hidden facepalm. Thanks XD May 26, 2015 at 16:44
  • Oh wow, talk about being the simple stuff.
    – Kallaste
    Aug 5, 2021 at 21:40
4

Hold together Option+Command+esc and then relaunch "Finder" that will solve your problem instantly. If the problem persists, please try reinstall Mac OS X by Command+R after rebooting.

1
  • You might not want to claim it "will" solve the problem instantly if in the next sentence you plan to say, "if it persists." In fact, your first directive may solve the problem sometimes, but not always.
    – Kallaste
    Aug 5, 2021 at 21:42
2

I've just wanted to share what has just worked on my system (10.12.6):

sudo killall sharedfilelistd Finder

and my Favourites are back.

1
  • Thank you! I had tried killing sharedfilelistd on it's own, messing with plist files, among other things - this seemed to be the final thing I needed to restore my favourites on 10.14
    – Someguy123
    Dec 1, 2022 at 5:14
-3

I had same problem on Yosemite. Hovering over "Favorites" and clicking "Show" worked.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .