Since updating to OS X 10.8.3 on my MBP, my keyboard backlight does not come on until I enter my password and my desktop comes up. This makes it very difficult to enter my password at night with low light because the keys are not backlit.

How can I enable the keyboard backlight before password entry?

  • Can you explain the exact steps you are taking here? Are you starting the machine from cold? Also, what MBP model do you have? I've just tested on my mid 2009 MBP, by selecting Login Window from the Fast User Switching menu, and my keyboard backlight does respond to changes in ambient light level whilst it is sitting at that login screen waiting for me to log in.
    – Ashley
    Commented May 19, 2013 at 13:52
  • I have a MBP 13 Mid 2010. This happens when I start the machine from a complete shutdown. When I press the start button my logon screen comes up but my backlight on my keyboard does not light up. After I enter my password and my home screen comes up it is then when the keyboard lights up. Using F5 and F6 once the keys are lit still works as normal. Before I upgraded to 10.8.3 my keyboard backlight would come on right after I pressed the start button. Any suggestions on how to get the keyboard backlight to come on after pressing start and before I have to enter my password?
    – user49683
    Commented May 19, 2013 at 17:14
  • 3
    while my machine is waiting for me to enter my password, the keyboard backlight stays off. It only comes on after I enter my password. At night I can not see the keys to enter my password without using the light from the display to help see the keys.
    – user49683
    Commented May 19, 2013 at 17:18
  • I have the same problem after opening my MacBook Pro 2012 from sleep, when it asks for password. I've noticed that the special keys like Shift, Control, etc will put the backlight on, but the letter and number keys won't. OS 10.14.2.
    – Chalky
    Commented Dec 28, 2018 at 19:39
  • This is pretty ridiculous. The default is for the keyboard to be illuminated after password is entered, so you'd think it would also be the default for before the password is entered. It's actually quite annoying. Still the case with Catalina. Commented Mar 7, 2020 at 1:13

2 Answers 2


When FileVault is enabled it encrypts everything on the SSD and doesn't allow even the computer to have access to that data until you enter your password. Including the software that loads during startup which would normally activate the backlighting on your keyboard and the touch-bar.

After you enter your password on startup the decryption process begins and all of those necessary pieces of software start to load. Making your keyboard backlight turn on and your touch-bar activate.

Here are your 2 choices:

  1. Accept it and remain using FileVault (my recommendation)
  2. Turn off FileVault (which I really do not recommend)
  • 6
    You'd think the keyboard buttons for brightness and keyboard light would still "just work" but NOPE! Not with FileVault turned on.
    – Beltalowda
    Commented Jan 11, 2018 at 4:36
  • OMG, it seems FileVault is so powerful that it can encrypt LEDs :o (it's sarcasm, it's simply bad design of the keyboard backlight mechanism).
    – hans
    Commented Aug 23, 2022 at 8:39

Assuming you are FileVaulted, fold your screen down just short of crushing your fingers. The light is sufficient to illuminate the kbd enough to be able to enter your pwd.

  • 2
    This simple solution seems only one reliable solution for now. Please upvote!
    – Vlad
    Commented Aug 11, 2021 at 19:40
  • ... done for years .. till I realized, I could set a brighter login background (OnyX), so the fold would be greater ^^
    – BananaAcid
    Commented Oct 31, 2021 at 17:16

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .