I have a 5 year old Seagate USB2 drive for backups, used for a few months with time machine on my Retina MBP.

Lately, I've been getting an error that it was improperly ejected (I didn't actually eject it), and I can hear the drive churn endlessly on its own. I can't remount it, its power button doesn't respond, I have to power cycle it, then it mounts again and seems to work. Until the next incident.

Is it dying on me? It's old but has only been lightly used, until recently.


I've had a similar problem with a 2 TB Fantom drive. Worked flawlessly for years, then it started to spontaneously unmount for no apparent reason. Time Machine being on or off doesn't have an effect.

It had been chained through another USB device (a MiniStack drive), and simply by taking it off the chain and plugging it directly into the Mac, I solved the problem.

Before ditching the drive, try changing USB cables and changing the routing (even a different USB port on the Mac.) Five years is a bit old for a hard drive, but it's not unreasonable.


Sounds like this drive is on its last legs, given that it spontaneously dismounts and then churns. Inexpensive USB3 drives with larger capacities exist for probably less than you paid 5 years ago for this aging drive.

Go for a replacement - you won't be sorry when you really need to restore something important. Why take the chance that the drive will fail tomorrow, tonight, or even five minutes from now?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .