3

Having installed both rEFInd 0.6.10 (updated to 0.6.11) via its install.sh and Ubuntu 13.04 on another partition I can now choose on a MacBook Air to boot either MacOS or Linux.

When running MacOS and closing and soon re-opening the lid, everything is fine, but after a longer time of closed lid, the machine is not waking/starting up. Instead I have to long-press the power button and then press it again to boot the machine.

1

If you want to prevent Macbook going from sleep mode into standby mode (dump RAM to SSD) too soon, you could also adjust by changing pmset's standbydelay value.

sudo pmset -g to check current setting

sudo pmset -a standbydelay [value] to update settting

But instead of changing pmset configuration (which affects your battery life), try using the original rEFIt instead, the installation is as simple as the forked project rEFInd, and I no longer experience any wake-up problem on my Macbook Air 5.2 (Mid 2012 version/OS X 10.8)

Reference Links:

http://refit.sourceforge.net/

https://askubuntu.com/questions/295105/refind-breaks-standby-mode-on-macbook-air-5-2/296514

  • With rEFIt installed OSX wakes up nicely, and refit offers an entry of the previous installed rEFInd where I can still boot Ubuntu, fine. Cheers – type May 18 '13 at 23:36
3

I had the same exact issue with my MacBook Pro and I have rEFInd installed as well. I resolved the problem disabling the autopoweroff option with pmset. See this answer.

  • 1
    Thanks a lot, seems to have worked already by resetting SMC. – type May 16 '13 at 20:03
  • Actually not, MBA was on AC power when tested, so it didn't go into Deep Sleep ... – type May 17 '13 at 7:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .