3

I'm continually hitting Alt+Left Arrow to move navigate within a cell in Numbers, and inadvertently inserting new rows.. How can I disable all the Alt+Arrow shortcuts?

I've tried changing the Application specific keys in System Prefs > Keyboard, and my new keys work, but the old remain active. Is there a tidy oneliner to paste into the terminal?!

Edit:

Hmm.. I can't replicate the problem that I'm asking about! ATM when I Alt+Enter into a cell to edit, Alt+Left Arrow is not adding a column! Maybe I'm mashing some other keys in there intermittently?

BTW, I've also tried setting Alt+Left Arrow to Bring All Windows to Front but that disabled using Alt whilst editing the cell.

2
  • bonus points for achieving this in any app!
    – ptim
    May 16, 2013 at 11:16
  • The alt-right is dangerous indeed. And the alt-left...who knows?
    – owlswipe
    Jan 31, 2017 at 23:22

2 Answers 2

1

You can edit the plist directly:

defaults write com.apple.iWork.Numbers NSUserKeyEquivalents '{"Add Column Before"="\0";"Add Column After"="\0";}'

It overwrites custom shortcuts set in System Preferences, but you could also edit the plist in a text editor after converting it to XML:

plutil -convert xml1 ~/Library/Preferences/com.apple.iWork.Numbers.plist
6
  • fantastic!! exactly what i was hoping for! If I edit the plist in xcode, what type of value should I enter for the key? I've tried string(\0) and bool(NO) with no luck…
    – ptim
    May 17, 2013 at 1:26
  • 1
    Escape sequences like \0 only work in old-style property lists. You can use � in an XML plist or a literal NUL character in Xcode's property list editor.
    – Lri
    May 17, 2013 at 14:30
  • hmm.. feeling dense! not sure how to enter a NUL literal into the plist via xcode.. I am: opening the plist, adding a key 'Add Column After' (string) then I've tried a couple of options: empty string, Ctrl-Shift-2, 'NULL', then opening numbers hoping that Add Column After will no longer work.. what am i missing? tx :)
    – ptim
    May 18, 2013 at 14:47
  • You can use printf %b '\0'|pbcopy or drag it from the Unicode view in CharacterPalette.
    – Lri
    May 18, 2013 at 16:09
  • 1
    Apparently it doesn't work for disabling ⌥← and ⌥→ in Numbers. This method does work with most shortcuts that have menu items though.
    – Lri
    May 19, 2013 at 16:12
0

Just had a quick look at this in Numbers.app 4.0.5, and I've found that by overriding the default keyboard shortcuts, the problematic behaviour is resolved.

Now if I hit Alt+Enter to edit the cell contents, I can hit Alt+Right and Alt+Left to navigate the text without adding any new columns (holding Shift to select text works fine, too).

The relevant menu items to override are:

  • Add Column Before
  • Add Column After

Docs: macOS Sierra: Create keyboard shortcuts for apps

keyboard shortcuts

1
  • I someone else verifies that this works for them on OSX 10.12, Numbers.app 4.0.5 then I'll accept the answer...
    – ptim
    Feb 1, 2017 at 1:14

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .