8

When I am using Chrome for web development I like to have it open on the same space as where I am using my code editor.

Chrome is currently assigned to a different space than my code editor so usually a drag it to that space when I am working.

If I open a new window with Chrome (not a tab), to do non-work stuff, when I open the new window it switches to the space it is assigned to without taking the new window with it. My mac then won't let me switch the the space Chrome is actually active on without first deselecting Chrome as the active application.

So in order to move to that space I need to make another application active, then shift to the space Chrome currently resides in, and then move the new window.

Edited, rephrase necessary... :P

  • Definitely difficult to understand question :) – Ruskes May 15 '13 at 15:21
  • Ok changed it a bit see if that helps... – John E May 15 '13 at 15:28
  • What exactly are you asking? Are you just documenting a problem or are you hoping for a fix? You certainly bring up an interesting point. I tested a similar configuration, and the bug that had to do with the spaces was pretty significant. – bassplayer7 May 15 '13 at 16:16
  • Well I was wondering if anyone knew of a work-around besides making another application active. But also if others were experiencing the same issue. I feel like Lion is maybe a bit too big for its boot sometimes. – John E May 15 '13 at 16:38
  • I have the exact same issue. It's a new behavior but I can't figure out what chrome update or apple update caused the issue. – user50694 Jun 5 '13 at 22:32
7

This is because by default Chrome is assigned to the first space. I believe this problem arises when you install Chrome and then enable Spaces afterwards. I have also experienced the problem and it is frustrating.

Here is the solution:

  1. Find the Chrome icon in your Dock
  2. Right-click on it (or control + click with a one button mouse)
  3. Mouse-over the Options sub-menu
  4. Under "Assign To" set the option to "None"

Here is a screenshot:

assign Chrome to no fixed Space

  • 2
    I'm having the same problem, but this didn't solve it for me. – Jo Liss Oct 13 '13 at 20:56
  • 1
    Thank you SO MUCH, this was driving me absolutely insane. I'm not sure how this got switched on, but changing this to None has fixed the problem. If you're ever in Birmingham (UK), I owe you a drink. – Cal Leeming Aug 17 '15 at 13:03
0

In 10.8 System Preferences > Mission Control, there is an option called "When switching to an application, switch to a space with open windows for the application".

  • I already have this option selected. It is more when you try to open a new window. When you try to do that it switches to an empty space because I have moved it to a space that isn't the native one. – John E May 15 '13 at 20:03

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .