5

I have been struggling to get Windows 8 installed on a brand new Macbook Pro Retina. It seemed simple enough to just run Boot Camp 5 with a 16GB flash drive in the USB port and a Windows 8 Professional ISO sitting on the desktop with the intent of creating a bootable USB drive, but it's not working for me. After selecting the path to the ISO file, boot camp proceeds to format the flash drive, create the WININSTALL partition, and attempt to copy the contents of the ISO to it, but it fails.

The error message isn't all that helpful, but the console logs seem to indicate that there is some sort of problem remounting the flash drive after formatting:

5/15/13 2:05:05.609 AM fseventsd[40]: could not open <</Volumes/WININSTALL/.fseventsd/fseventsd-uuid>> (No such file or directory)
5/15/13 2:05:05.609 AM fseventsd[40]: log dir: /Volumes/WININSTALL/.fseventsd getting new uuid: FD5D8B3E-A08E-4710-8925-CAA898FA70C3
5/15/13 2:05:05.679 AM fseventsd[40]: Events arrived for /Volumes/WININSTALL after an unmount request! Re-initializing.
5/15/13 2:05:05.679 AM fseventsd[40]: creating a dls for /Volumes/WININSTALL but it already has one...
5/15/13 2:05:07.176 AM diskmanagementd[857]: mount blocked by dissenter PID=857 (/usr/sbin/diskmanagementd) status=0xf8da0003 log=kDAReturnBadArgument message=(null)

I have tried rebooting, removing and re-inserting the flash drive, mounting, umounting, and reformatting. Boot Camp always winds up in the same place.

Any hints as to what might be going wrong?

Update: I've now cross-posted this to the Apple forums.

4
  • According to support.apple.com/kb/HT5639 you can't install Windows on an external drive: "Can I install Windows on an external drive? No. Installing Boot Camp on an external hard drive is not supported."
    – jaume
    Commented May 27, 2013 at 14:15
  • @jaume I'm not installing on an external drive. I'm trying to create a bootable flash drive from which to install onto the internal SSD. I have since been able to create the bootable flash drive on a PC and go from there, but I would still like to figure out this problem. Commented May 28, 2013 at 16:13
  • Aren't you trying to create a Windows 8 bootable flash drive with Boot Camp? Isn't that technically equivalent to installing Windows on an external drive? Or am I missing something obvious?
    – jaume
    Commented May 29, 2013 at 6:53
  • 1
    @jaume, Installing the OS on an external drive is different than using an external drive to boot and install the OS. The flash drive here is just functioning like the DVD disk that you get when you buy a copy of Windows in a box. The Boot Camp dialogue box actually even says "you need a USB flash drive".
    – Will
    Commented Jul 22, 2013 at 2:25

2 Answers 2

1

Have you tried to use a different flash drive? I have had issues particularly with SanDisk Cruzer flash drive that are unable to be used as boot devices because of the firmware on the flash drive. Try a different flash drive and see if you have the same result. I have an 8 GB Sony flash drive and a 4 GB Kingston flash drive that have never failed as bootable USB devices. Using the same process, I just could never get the SanDisk to work.

Otherwise burn the ISO to a DVD and and Bootcamp should be able to find it just fine.

1
  • MBP Retinas don't have DVD drives :-) In any case, I recently re-did the bootcamp install using windows 8.1 and it worked flawlessly on the same thumbdrive that I had all that trouble with previously. No idea why, but if I had to guess, I would guess that there was something goofy about the ISO image itself. Commented Nov 7, 2013 at 15:22
0

When I had this problem, I reformatted the external disk (USB) to MS-DOS FAT.

Opened up BootCamp and it copied the files all fine!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .