3

I am working on a slideshow in Spanish. Pages has the "More" tab on the inspector which allows you to change the language of the selected text / document, but Keynote lacks it.

I know you can spellcheck using Edit > Spelling > Spelling... but apparently this system spellchecker is independent from the document language. The checker will check in spanish, but spanish words in the document are still be underlined in red.

Is there any way to change this? Not only check for spelling in another language, but actually change the document's language and make the red lines disappear?

2

Turns out I figured it out not long after typing this question! I just thought I'd experiment a little and found out how to do it.

You change the language in Edit > Spelling > Spelling... and then reopen the document. That did it for me. I'm guessing it is a bug: I don't think having to close and open a document for language error display settings to make effect it's very intuitive, but I'm glad it can be done!

I'm posting this anyways to share the knowledge and in the hopes it will be useful to somebody else, struggling with those dotted red lines!

1

If you have the 6.2 (or later) version, you need to go to Edit > Spelling and Grammar > Show Spelling and Grammar. There you can set the spellcheck language.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .