0

I live in Indonesia and we use the dd/mm/yyyy date format as opposed to America's mm/dd/yyyy. Questions:

  1. I changed my Language settings to Indonesia region so that this date format would be recognized as a date in Excel. It worked, but somehow Excel won't recognize a comma as a delimiter for CSVs anymore. How shall I solve this?

  2. Is there a way to get Excel to recognize this date format without changing the Language settings?

Thanks

  • What version of excel do you have? – Ruskes May 13 '13 at 18:30
1

In Excel 2011, open a workbook,

Click on Format > Style and you get this window

enter image description here

In here click format again and you get this window

enter image description here

Pick the Date format you want, or make a custom format in your case dd/mm/yyyy

  • No sorry that's not correct. That's just to change the format of the Date that's in the cell, provided that Excel RECOGNIZES the string as Date. The problem is using United States standard Excel will look for month-date-year, but where I am from we use date-month-year. – rabbid May 14 '13 at 2:19
  • Maybe it would help if you show an example! – Ruskes May 14 '13 at 6:22
  • OK sure. Example: 31/01/2013, and try to set that as a Date. – rabbid May 14 '13 at 7:41
  • I did, and it works as 31/01/2013 than to check it i used -1 day formula, so it comes up with correct answer of 30/01/2013. Or -33 days = 29/12/2012 – Ruskes May 14 '13 at 8:24
  • I left it on US and added custom date format as dd/mm/yyyy in excel, and I also tried with Setting the excel on Indonesia-Indonesian. – Ruskes May 14 '13 at 8:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .