When trying to log into iCloud from System Preferences, I'm told

[appleid] is already signed in to iCloud

To use this as your primary iCloud account, delete it from Mail, Contacts, and Calendars and sign in again.

However, I can't delete the account from Mail, Contacts and Calendars. When I go to that preference pane, I'm prompted for my iCloud password, after which I'm told the account isn't verified. Checking at http://appleid.apple.com shows that the account is verified. Requesting that another verification email be sent is met with the following error:

Couldn't request a new verification email because of a server error.

Any ideas how to delete the account from Mail, Contacts and Calendars? I've deleted all other mail accounts. Removed the mail folders and plist files from ~/Library/. Rebooted. Tried adding a different apple id. Tried everything I could find from Google that looked even close. No luck. Help!

  • Quite a bit overboard, but reloading your computer would likely nail the computer part of the problem - if all else fails. More realistically, I would call Apple, and see if they can work through the Apple ID problem with you - especially since you can't get a confirmation email sent. It sounds more like an Apple ID problem then just your computer giving you trouble. – bassplayer7 May 13 '13 at 15:10
  • What happens when you go to the System Preferences pane of iCloud and click Sign Out? – Can Sürmeli May 17 '13 at 9:13
  • I can't sign out -- the button isn't available -- because I'm not signed in. When I try to sign in, I get the "...is already signed in..." message in the question. – highlycaffeinated May 17 '13 at 12:00

I had the same problem. Fixed it by turning off all sharing (the checkbox options on the right of the panel), THEN trying to delete again.

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .