28

How do you delete a file you have selected in a Finder window, without using the mouse?

delete doesn't do it.
When I looked it up, I was said that command-delete is supposed to do it, but it doesn't work for me.

  • I assume the CMD is enabled in keyboard preferences! – Ruskes May 12 '13 at 14:36
45

It should work in Finder by default, but did you press the right delete key?

  • Delete (⌫) is the key that is called backspace on other platforms
  • Forward delete (⌦) is the key that is called delete on other platforms
  • 7
    OMG. This is sick! I have spend hours trying to delete a file... and then used the terminal with "rm" – madlymad Jun 25 '15 at 11:18
  • I agree !! thanks... ;) that was not obvious at all ! :) – maycca Apr 11 '16 at 18:22
  • 2
    There are two "delete"-keys on my stupid Apple keyboard, neither of them actually deletes anything. You have two press Command+Delete?! But that of course only works for one of the two delete keys.^^ WTF?!?! – Max Binnewies Mar 15 '18 at 22:48
  • @MaxBinnewies in fairness a PC keyboard also has both a DEL and a backspace key, and once you're accustomed to using DEL to delete the character in front of the cursor, you're irritated when the key is missing e.g. on a Chromebook keyboard. – slim Apr 4 '18 at 11:00
  • I read Ron's answer to find out Cmd + Backspace works. I skimmed this answer and assumed it was telling me there's two keys -- Backspace and Delete (which I know) not that they're swapped on mac (which I didn't know!). An improvement to this answer for someone like me would be to add "The Delete and Forward delete keys are swapped compared to other platforms" – Michael Fulton Sep 28 '18 at 18:10
7

I had the same problem. Later I discovered that it was my own mistake. But also a mistake from Apple. On the extended keyboard with numeric pad there is a button says DELETE. (It's not on the short wireless keyboard) This is NOT the delete button for the combination Cmd-Delete. You have to use the button with the backarrow! So Cmd-Backarrow.

  • good point, it works for me – dresden Apr 16 '14 at 11:44
  • 1
    Yeah, works for me too. CMD + Backspace deletes files in Finder – Michael Fulton Sep 28 '18 at 18:07
3
  1. Look into "System Preferences → Keyboard keys" and make sure Command is enabled and mapped to the Cmd key. Check also custom shortcuts in the "Keyboard Shortcuts" panel.

    Keyboard preference panel of OS X

  2. Go to Finder, select a file, open the "File" menu and see what shortcut is associated to "Move to Trash".

    "File" menu of Finder

3

tl;dr: If ⌘-delete doesn't work, try ⌘-⌥-delete (command-option-delete) instead.

I had this problem on a new iMac with a standard Apple keyboard running the latest version of OS X (Mavericks 10.9.3 as of this writing). This was driving me crazy because I use ⌘-delete frequently, and I often switch between the iMac and my MacBook Air (running the same version of OS X) on which ⌘-delete works fine. I just discovered by chance and desperation that, for some reason, ⌘-⌥-delete (command-option-delete) does work. It's not as good as having the same keystrokes work on both machines, but at least now there's some keyboard shortcut I can use on the iMac.

UPDATE: For no apparent reason, ⌘-delete has started working.

  • and they say Apple is easier to use... 🙄 – Andz Mar 12 at 3:13
1

I experience that before. and my accidental solution is command + delete after that press command + backspace.

1

This may not help many, but here is how I restored "Command+delete".

A while back, I was convinced that this key combination for "Move to Trash" was not working in my macOS Sierra. So, in System Preferences > Keyboard > Shortcuts > App Shortcuts, I attempted to manually define a shortcut "Move to Trash". But, I was never allowed to assign the same "Command+delete" key combination.

A frustrating few weeks have passed until this morning. But, this morning, I was determined to restore "Command+delete" and once again went into the App Shortcuts pane. There, it occurred to me to DELETE the very shortcut and key combination I had been trying to define. So, I selected my "Move to Trash" Finder shortcut and clicked on the "minus" button to delete it.

Upon returning to the Finder, I was stunned to see "Command+delete" appearing to the right of "Move to Trash" again.

So, if you have tried many things to restore the "Command+delete" key combination for "Move to Trash", one thing I would like for you to try is this:

  1. In System Preferences > Keyboard > Shortcuts > App Shortcuts, create a Finder shortcut for "Move to Trash" and assign whatever key combination that the system accepts.
  2. Go back to the Finder and confirm that your key combination works.
  3. Now, return to the App Shortcuts pane, select the shortcut you created, and press the "minus" sign to delete the shortcut.
  4. Go back to the Finder and see if "Command+delete" has return to "Move to Trash.
0

I accidentally discovered that Fn + Delete did the job for me in macOS Sierra.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .